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About this Manual

1	 ABOUT THIS MANUAL

IQVISION is a supervisor tool for Trend Building & Energy Management Systems (BEMS). It is based on the 
powerful Niagara 4 (v4.2) software framework and uses the Trend IP Network Driver.

This manual describes how to install IQVISION and configure the Trend Driver to allow Trend system data to be 
made accessible to the Niagara framework. 

It consists of the following main sections:

About IQVISION
This section gives an introduction to basic system principles and the IQVISION user interface.

Securing IQVISION
This section provides guidance on security issues to be considered when installing and using IQVISION.

Engineering Procedure
This section describes the process of engineering IQVISION.

Installing IQVISION
This section describes how to install IQVISION.

Licensing IQVISION
This section describes how to obtain and install IQVISION license files.

Initial Setup
This section covers the procedures that must be followed to get IQVISION ready for use.

Building a Site
This section describes how to configure IQVISION to read data from a Trend system/site.

Controlling Complex Occupation Times
This section describes how to configure IQVISION to control occupation times on the Trend system centrally.

Configuring Alarms
This section describes how to configure IQVISION to receive and process alarms.

Creating Schematics (PX Pages)
This section gives basic guidance on creating PX Pages that enable end users to navigate and access the 
system.

Set Up IQVISION Users
This section describes how to configure users in IQVISION to ensure each user only has access to the 
appropriate information.

Backup & Restore
This section describes how to backup/restore the IQVISION configuration.

Using IQVISION
This section covers general day-to-day operating procedures aimed at end users.

Migration Tool
This section describes how to use the Migration Tool to migrate data and schematics from other Trend tools 
(e.g. 963 and IQ®SET) into IQVISION.

It is assumed that you understand how to use Niagara 4. For further information you should refer to the Niagara 
documentation which is installed during the IQVISION installation. It can be accessed from the IQVISION Help 
menu.
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1.1	 Conventions Used in this Manual

There are numerous items and instructions in this manual, the conventions below are designed to make it quick and 
easy to find and understand the information.

▪▪ Menu commands are in bold type.
▪▪ Buttons, and options in dialogue box that you need to select are in bold type.
▪▪ The names of text boxes and dialogue boxes are in bold type.
▪▪ Key combinations that you should press appear in normal type. If joined with a plus sign (+), press and 

hold the first key while you press the remaining one(s). For example CTRL+S indicates holding down 
the control key while pressing S.

▪▪ Text you should enter is in Italic type.

1.2	 Contacting Trend

Head Office
Trend Control Systems Limited
Albery House
Springfield Road
Horsham
West Sussex
RH12 2PQ

Tel: +44 (0) 1403 211888
Fax: +44 (0) 1403 241608

Details of regional offices can be found on our web site.

Internet
Our company web site (www.trendcontrols.com) provides information about our products and us. Accredited 
partners should contact our PNet support web site (https://partners.trendcontrols.com).

Technical Support
Our support department provides technical support during normal office hours. Before contacting our support 
department ensure that you have your Technical Support PIN number available, without this we will be unable to 
provide you with any support.

Tel: +44 (0) 1403 226600
Email: trendts@trendcontrols.com
Fax: +44 (0) 1403 226310

Note: Trend Technical Support are only able to provide support for IQVISION and the Trend driver features described 
in this manual. They are unable to provide support for 3rd party drivers and undocumented aspects of IQVISION’s 
operation.

Technical Publications
Please send any comments on this or any other Trend technical publication to techpubs@trendcontrols.com.

http://www.trendcontrols.com
https://partners.trendcontrols.com
mailto:trendts@trendcontrols.com
mailto:techpubs@trendcontrols.com
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2	 ABOUT IQVISION

IQVISION is a supervisor tool for Trend Building & Energy Management Systems (BEMS). It is based on the 
powerful Niagara 4 software framework. This section describes the key features of IQVISION and its user interface, 
and introduces some of the terminology used.

Using the supplied Trend IP Driver, IQVISION can connect to multiple Trend sites and access site data in order to 
monitor or adjust the site operation. System data is held within a database and is accessible in raw format or presented 
in specially-designed graphical pages known as schematic or PX Pages.

IQVISION connects to the Trend network over Ethernet using a vCNC in a Trend device. This gives access to the 
Trend devices on the associated (local) Trend LAN and, where a vINC (or INC) type node is also present, access to 
devices on the wider internetwork.

IQVISION

Trend

IP Driver

Ethernet

Client

Devices

vCNC

Controller

vINC

Trend LAN

Internetwork
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2.1	 IQVISION Architecture

2.1.1	 Platform

The Platform is the topmost level of configuration and may be compared to the control panel on a PC. It is in this area 
of IQVISION where you can set up: 

▪▪ Communications
▪▪ Install licenses
▪▪ Fault find issues via the Application Director

Access to the Platform settings requires the user to login using the same credentials required to login to the PC.

2.1.2	 Station

The Station manages communications with the Trend system(s) and acts as a ‘container’ for all other configuration 
settings and functions. These include:

▪▪ Services - such as alarm listening and monitoring and the IQVISION Migration Tool.
▪▪ Drivers - for managing access to data in the Trend system(s) and other systems.
▪▪ Files - schematic/PX Pages used to present system information on remote client devices.

Access to the Station settings requires the user to login. Initial system configuration is achieved using a default 
admin/engineering user account which is set up when the Station is created. Once configuration is complete further 
accounts can be added that grant different users specific access rights according their role (see “Set Up IQVISION 
Users” on page 83).

2.1.3	 Trend IP Driver

The Trend IP driver defines the communication settings to a Trend system and provides access to data held in its 
controllers and devices, including:

▪▪ Points - input values from Sensor, Knob, Switch and Digital Input modules, and output values for 
Driver modules. IQVISION also supports read/write access to any other strategy module parameter 
that is accessible via text comms.

▪▪ Schedules - for viewing and adjusting occupancy times (Time Schedule modules).
▪▪ Histories - values logged in Plot modules.
▪▪ Alarms - for monitoring alarm messages generated within the Trend system.

A separate Trend driver is required for each Trend Network (or Site) that you wish to supervise within IQVISION. 

2.1.4	 Other Drivers (open points)

The Niagara framework supports a wide range of additional drivers, suitable for interfacing with other manufacturer’s 
building automation systems and products. This enables the monitoring and control of these systems to be fully 
integrated with the management of a Trend system within a common supervisor.

Support for other drivers requires one or more additional open driver packs. For details of order codes and point 
counts refer to the IQVISION Data Sheet (TA201381).
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2.2	 User Interface

2.2.1	 Application (Host PC)

This section introduces the main features of the IQVISION user interface.

Nav Tree

Locator Bar

Palette

View Changer

View Pane

Menu Bar
Tool Bar

2.2.1.1	 Nav Tree (navigation panel)

The Nav tree (or navigation panel) provides the principle means of navigating around the elements, folders and files 
in IQVISION. Once configured it is here that you can view devices and points in a Trend system.

For help on using the Nav tree, refer to page 106.

2.2.1.2	 Palettes

Palettes are useful when configuring certain elements in the system. There are many Palettes available, but the most 
commonly used in IQVISION are:

▪▪ Alarm Palette 	 for configuring Alarm handling
▪▪ Schedule Palette 	 for configuring Time Schedules
▪▪ History Palette	 for configuring Histories (Plots)
▪▪ KitPX Palette		 for configuring Graphics and accessing default images.

For help on opening and closing Palettes, refer to page 106.

2.2.1.3	 Locator Bar

The locator bar provides similar functionality to the Nav tree. As you navigate around the file system the locator bar 
will update to show the current location and view.

For help on using the locator bar, refer to page 106.

2.2.1.4	 View Pane & View Changer

The view pane is the principle work space for IQVISION. When you first run IQVISION it will display the home 
page (shown above). As you navigate through the system and select different items in the Nav tree, the view pane will 
change to show different information or configuration pages. 

Some elements may provide more than one type of view. For help on selecting the required view, refer to page 106.
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2.2.2	 Client Devices

IQVISION can be accessed via web clients providing that an IP connection is possible between the client device and 
the PC running IQVISION.

Once accessed IQVISION provides a similar user experience to the user as when it is accessed on the main PC 
depending on the device being used to access.
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3	 SECURING IQVISION

3.1	 Introduction

The purpose of this section is to provide the information necessary for those involved in the installation and 
maintenance of a product or system to understand the requirements for configuring and managing the security of the 
product or system.

Additional information may be obtained from:

▪▪ General Security Best Practice for Trend IP Based Products Information Sheet (TP201331)
▪▪ NiagaraAX Hardening Guide.

Both documents are available from the Trend PNet web site (https://partners.trendcontrols.com).

3.2	 Disaster Recovery Planning

When developing the disaster recovery plan ensure that it includes ALL data required to restore system operation, 
including:

▪▪ Configuration files for platform(s) and station(s);
▪▪ Database objects;
▪▪ Licence and certificate files;
▪▪ Station Backup;
▪▪ Station Copies;

See “Backup the Configuration” on page 91 for details.

3.3	 Physical and Environmental Considerations 

The PC running IQVISION should, where possible, be secured against unauthorised physical access.

3.4	 Security Updates and Service Packs

Ensure the PC running IQVISION and any client devices have the latest operating system updates installed, and the 
latest version of IQVISION is being used.

Trend software is tested against the latest service packs and updates applicable at the time of release. For significant 
operating system and Java updates / service packs, please check the Trend PNet web site (https://partners.
trendcontrols.com) for any compatibility issues.

3.5	 Virus Protection

Ensure the PC running IQVISION and any client devices are running virus protection software, and the virus 
definitions are kept up-to-date.

Some virus protection software may have an adverse impact on the performance of IQVISION. In such cases request 
that the IQVISION directory be excluded from on-access scan.

Further details can be found on the Trend Partners web site (https://partners.trendcontrols.com).

http://pnet.trend-controls.com
http://pnet.trend-controls.com
http://pnet.trend-controls.com
http://pnet.trend-controls.com
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3.6	 Network Planning and Security

It is recommended that the Ethernet network used by the BEMS system is separated from the normal office network 
using an air gap, or virtual private network. Physical access to the Ethernet network infrastructure must be restricted. 
You must also ensure that the installation complies with your company’s IT policy.

The use of a Firewall and Intrusion Detection System (IDS) from a reputable provider of security products is 
recommended for any IQVISION installation. Follow best practice for the products chosen as well as any corporate IT 
policy where the installation is made. Lock down the products to the particular port you’ve configured for IQVISION 
HTTPS and HTTP.

Always follow the guidelines in the ‘General Security Best Practice for Trend IP Based Products Information Sheet’ 
(TP201331).

You must also take steps to ensure the security of any other networks connected to IQVISION (e.g. BACnet).

3.7	 Virtual Environments

Follow best practice for the products chosen as well as any corporate IT policy where the installation is made. 

3.8	 Securing Wireless Devices

If a wireless network is being used it must be secured according to your company’s IT policy.

3.9	 System Monitoring

For any IQVISION installation, especially when connected to the internet, Trend recommends the use of an Intrusion 
Detection System (IDS) from a reputable provider of security products. Follow best practice for the products chosen 
as well as any corporate IT policy where the installation is made. 

IQVISION logs changes made to its own configuration and adjustments to the Trend control system. Many IDS 
and firewall products offer a complete solution for recording all the traffic coming in and out of the IQVISION PC, 
providing users with the ability to record all activity at the lowest level.

3.10	 Securing Access to the Operating System

Ensure the PC running the IQVISION and any PCs used for IQVISION clients are secured according to your 
company’s IT policy.

3.11	 Access Control

All IQVISION files should be protected from read and write access by people and software not authorized. Trend 
recommends following best practice for securing system objects, such as files, and using access control appropriately.

If Windows users are granted access to the filing system location of the IQVISION project then it is possible for them 
to inadvertently (or deliberately) open, delete or edit any of the configuration and data files of independently of their 
IQVISION workgroup settings.

3.12	 Securing IQVISION

The IQVISION software should be configured during installation and operation following best practice. Follow the 
installation procedure as described in this manual. In addition, refer to the Niagara 4 help system and Niagara 4 
security guidelines.

3.12.1	 Default Admin User

Initial system configuration is achieved using a default admin/engineering user account which is set up with a strong 
password when a Station is created. 
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3.12.2	 Passphrase

The passphrase, specified during the IQVISION installation process, protects sensitive data on any station that you 
create and will be required if the IQVISION station is to be moved to another PC e.g. moved to the site PC, or restored 
after a PC failure. 

3.12.3	 Set up Other Users

Once configuration is complete (using the default admin user) further user accounts must be added that grant different 
users specific access rights according their role. IQVISION enforces the use of strong passwords. 

For further details, see “Set Up IQVISION Users” on page 83.

3.13	 IQVISION Security Check List

�� Latest version of IQVISION is being used.
�� IQVISION installation files, configuration files (including station backup), certificates and licences are 

included in disaster recovery plan.
�� The PC running IQVISION should, where possible, be secured against unauthorised physical access.
�� The Ethernet network (and any other networks) that the PC is connected to is secured, e.g. by the use 

of firewalls and intrusion detection systems.
�� The PC is running the latest version of the Windows operating system, with all updates and service 

packs.
�� The PC is running virus protection software.
�� Appropriate user accounts are set up on PC and access to files is restricted to only those who are 

authorized.
�� IQVISION is configured to use HTTPS using a certificate from a trusted Certificate Authority.
�� IQVISION users are configured as required.
�� Ensure IQVISION is configured to backup data regularly to a secure location as per your company’s 

backup policy.
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4	 ENGINEERING PROCEDURE

Before IQVISION can be used it must be engineered to communicate with the required devices and to present the 
information to the user. The following steps are recommended:

▪▪ Installing IQVISION
▪▪ Licensing IQVISION
▪▪ Initial Setup
▪▪ Building a Site
▪▪ Connect to TONNs
▪▪ Connect to 3rd Party Systems
▪▪ Controlling Complex Occupation Times
▪▪ Configuring Alarms
▪▪ Creating Schematics (PX Pages)
▪▪ Set Up IQVISION Users
▪▪ Backup the Configuration
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5	 INSTALLING IQVISION

This section describes how IQVISION should be installed to ensure that it operates correctly. The following steps 
are required to install IQVISION:

▪▪ Check installation requirements - see ‘Installation Requirements’.
▪▪ Obtain the software - see ‘Obtaining the IQVISION Software’.
▪▪ Install the software - see “Installing the IQVISION Software” on page 20.
▪▪ Install the Platform Daemon (if required) - see “Installing the Platform Daemon” on page 20
▪▪ Configure the Windows Firewall - see “Configuring the Windows Firewall” on page 21

5.1	 Installation Requirements

Before installing, or upgrading, ensure that the PC meets the system requirements. Refer to the IQVISION Data 
Sheet (TA201381).

The PC on which IQVISION is to be installed must have TCP/IP access to a virtual CNC within the Trend network.

5.2	 Obtaining the IQVISION Software

1.	 Log in to the Trend Approved Partners site (PNet) at https://partners.trendcontrols.com 

Note: A username and password is required to access the site.

2.	 Go to the Downloads area and click the IQVISION v2.0.zip file and save it to an empty folder on the PC.

https://partners.trendcontrols.com
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5.3	 Installing the IQVISION Software

1.	 Unzip the IQVISION v2.0.zip file into an empty folder.
2.	 Log in to the PC as someone with Administrator rights.

Note: It is recommended that you close all other programs before installing IQVISION. However, do not close 
any virus protection software.

3.	 Run ‘Installer_x86.exe’ (for 32-bit operating systems) or ‘Installer_x64.exe’ (for 64-bit operating systems), 
and wait for the first installation screen to appear.

4.	 Follow the on-screen instructions to:

▪▪ Read and accept the license agreement.
▪▪ Change the destination folder (if required). The default path is ‘C:\TrendControlSystems\IQVISION’.

Note: If you enter a new path it must not contain spaces.

▪▪ Add shortcuts to the Start Menu and Desktop.

Once the installation is complete the following screen is displayed.

Note: During the installation you will be prompted to create a passphrase which ensures sensitive data on 
any station that you create  is protected. Ensure that you remember it and keep it safe as it will be required to 
move the configured IQVISION to another PC.

5.	 Leave both options selected and click the Finish button.

5.4	 Installing the Platform Daemon

If there are other instances of Niagara (or IQVISION) on the same PC then the Platform Daemon must be installed. 
This will typically be set up during the installation process. It can also be installed and run manually.

1.	 Click Start and choose All Programs.
2.	 Navigate to the Trend Control Systems > IQVISION folder.
3.	 Click Install Platform Daemon.

After a few seconds a command window should briefly appear with the following message:

installdaemon: Niagara service successfully installed.
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5.5	 Configuring the Windows Firewall

You may need to configure the Windows Firewall to allow IQVISION to communicate correctly.

To configure the Windows Firewall:
1.	 Open the Windows Firewall.

▪▪ In Windows 10 or 8, type ‘Windows Firewall’ in the Search box;
▪▪ In Windows 7, click the Windows Start button, type ‘Windows Firewall’ in the Search box. 
▪▪ Click Windows Firewall from the list of search results.

2.	 Click Allow a program or feature through Windows Firewall. The Allowed programs and features list 
is displayed.

3.	 Scroll down the list and check that entries exist for Niagara Runtime Launcher, Niagara Station Launcher, and 
Niagara Workbench for your IQVISION installation folder. If these programs do not appear in the list you 
will need to add them (see procedure below).

Note: Each installed instance of Niagara requires its own entries in the Firewall settings.

4.	 If you need to change any settings click Change settings and edit the checkboxes as required.

To add programs to the firewall:
1.	 Open the Allowed programs and features list as described above.
2.	 Click Change settings.
3.	 Click Allow another program. The Add a Program dialogue box is displayed.

4.	 Click Browse and navigate to the Trend Control Systems | IQVISION | bin folder.
5.	 Double click the program to be added.

To add Niagara Runtime Launcher select nre.exe
To add Niagara Station Launcher select station.exe
To add Niagara Workbench select wb_w.exe

6.	 The program will appear highlighted in the Add a Program dialogue box. Click Add to add the program to 
the firewall list. The dialogue box will close.
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7.	 Repeat steps 3 through 6 to add the other programs.
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6	 LICENSING IQVISION

Before IQVISION can be used, it must be licensed. The licence will allow you to run the application on a single PC. 

6.1	 Obtain an IQVISION Licence and Certificate

When an unlicenced installation of IQVISION is run you will be prompted to email certain details to Trend in order 
for them to provide the relevant licence and certificate files.

To obtain a licence:
1.	 Launch the IQVISION application, e.g. from the Start menu point to All Programs > Trend Control Systems 

> IQVISION and then click IQVISION. The Request License dialogue box is displayed.

2.	 Email the requested information to trendts@trendcontrols.com including the email address you would like 
the licence files sent to.

3.	 Click Exit to close the dialogue box.

The customer services department will process your request, and email the licence and certificate files to the specified 
email address.

6.2	 Install the IQVISION Licence

Your IQVISION licence is emailed to you as a ZIP file containing a number of licence and certificate files which need 
to be installed on the PC containing IQVISION, this can be done in two ways:

▪▪ Automatically 
▪▪ Manually

6.2.1	 Automatic Licencing

IQVISION can be licenced automatically via the global license server providing the PC has internet access. If this is 
the case when IQVISION is run after your licence request has been processed it will automatically be licenced and 
the files copied to the required folder.

6.2.2	 Manual Licencing

To install the licence and certificate files:
1.	 Copy the ‘Licences.zip’ file to the PC hard disc.
1.	 Extract all the files from ‘Licences.zip’ to an empty folder. The folder should now contain six files.
2.	 Copy the three ‘.licence’ files to the ‘C:\TrendControlSystems\IQVISION ...\security\licenses’ folder.
3.	 Copy the three ‘.certificate’ files to the ‘C:\TrendControlSystems\IQVISION ...\security\certificates’ folder.
4.	 You will now be able to launch the IQVISION application.

mailto:trendts%40trendcontrols.com?subject=
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6.3	 Updating a Licence

If you purchase a licence upgrade, e.g. for additional points, you will be emailed the updated licence files as a ZIP file 
containing a number of licence and certificate files and it will be necessary to upgrade the IQVISION licence. If the 
IQVISION PC is connected to the internet this should happen automatically - see “Automatic Licencing” on page 
23, alternatively the files can be copied manually - see “Manual Licencing” on page 23.
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7	 INITIAL SETUP

When IQVISION is run for the first time you will need to work through an initial setup procedure which involves 
the following steps:

▪▪ Launch the IQVISION Application
▪▪ Open the Platform
▪▪ Create a New Station
▪▪ Open the Station

7.1	 Launch the IQVISION Application

1.	 Click Start and choose All Programs.
2.	 Navigate to the Trend Control Systems > IQVISION folder.
3.	 Click IQVISION. The IQVISION application window will open:

Note: For an overview of the IQVISION user interface, see page 11.

4.	 Proceed to “Open the Platform” on page 26.
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7.2	 Open the Platform

1.	 In the Nav tree right-click on MyHost and choose Open Platform. The Connect dialogue box is displayed.

2.	 In the Type box select Platform Connection. Leave other settings at their default values.
3.	 Click OK. The Authentication dialogue box is displayed.

Note: If a ‘Cannot display page’ error appears, ensure that the Platform Daemon has been installed - see 
“Installing the Platform Daemon” on page 20.

4.	 Enter the Username and Password that you would normally use to login to the PC.

Note: For security it is recommended that the Remember these credentials box is left unchecked.

5.	 Click OK. A ‘Platform’ item will now appear in the Nav tree and various platform objects will appear in the 
view pane.

6.	 Proceed to “Create a New Station” on page 27.
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7.3	 Create a New Station

1.	 From the Tools menu select New Station. The New Station Wizard is displayed.

2.	 Under Station Templates click IQVISIONSupervisor.ntpl to highlight it.
3.	 Type a suitable name in the Station Name box.

Note: If a station already exists with that name you will be prompted to delete the existing station. You must 
select Yes to proceed.

4.	 Click Next.

5.	 Type a password in the Password for admin User box.

Note: The password must have a minimum of 10 characters and include at least one capital letter, one 
lowercase letter and one numeral (digit).

6.	 Retype the password in the Confirm Password for admin User box.

Note: This password is for the ‘admin’ and should be reserved for engineers.
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7.	 Select the copy it to secure platform for “localhost” with Station Copier option.
8.	 Click Finish.
9.	 If you have not already logged in to the Platform the Authentication dialogue box is displayed, go to step 10. 

If you have already logged into the Platform, go to step 11.

10.	 Enter your Username and Password (login credentials of the PC) and click OK.
11.	 If a station with the same name already exists, you will first be prompted how to proceed.

12.	 Specify the required option.
13.	 Click Next. A dialogue box enabling you to specify the start-up options is displayed.

14.	 Select the required start-up options.

Option Description
START AFTER INSTALL Select this option if you want to start the station as soon as it has copied 

(recommended).

Note: When developing several Supervisors other stations will need to be 
stopped.

AUTO-START Select this option if you want the station to be started when the PC is 
restarted (recommended).
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15.	 Click Next.

16.	 Click Finish. A progress update is displayed.

17.	 When the process is complete, click Close. The Open Application Director dialogue box is displayed.

18.	 Click Yes. The Application Director is displayed. Check that a ‘Station Started’ message is shown.

19.	 Proceed to “Open the Station” on page 30.
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7.4	 Open the Station

1.	 In the Nav tree right-click on MyHost and select Open Station. The Connect dialogue box is displayed.

2.	 In the Type box select Station TLS Connection. Leave other settings unchanged.
3.	 Click OK. The Authentication dialogue box is displayed with the default ‘admin’ user selected.

4.	 Type the appropriate password in the Password box (i.e. the password specified when the Station was created).

Note: For security it is recommended that the Remember these credentials box is left unchecked.

5.	 Click OK.
6.	 After a short delay, the chosen station name will appear in the Nav tree and the view pane will show a 

summary of Station parameters (Station Summary view):

7.	 Proceed to “Building a Site” on page 31.



IQVISION Configuration Manual TE201382 Issue 4, 13-Feb-2017� 31

Building a Site

IQVISION Configuration Manual TE201382 Issue 4, 13-Feb-2017� 31

8	 BUILDING A SITE

Building a site within IQVISION involves creating a database that reflects the structure, devices and points within 
the associated Trend system. A point represents the value or state of an item in the system, e.g. the value of a 
temperature sensor. 

There are two methods of building a site within IQVISION:

▪▪ Using the Migration Tool (recommended)
▪▪ Using Manual Site Discovery

You can use either or both methods to build your site, according to your requirements.

IMPORTANT: It is best practice to only add the points required for use in IQVISION. Adding unwanted points will 
increase memory usage and affect the remaining licence count.

8.1	 Using the IQVISION Migration Tool

The Migration Tool allows you to import device data from other Trend tools like 963 and IQSET for use in IQVISION. 
Schematic files from 963 can also be imported and converted in to PX Pages in IQVISION. This is useful for quickly 
setting up IQVISION for use with existing sites or where site designers wish to reuse previously designed interface 
components when setting up a new site.

The Migration Tool can be used whether or not IQVISION is connected to the actual site. For further details refer to 
“Migration Tool” on page 95.

8.2	 Using Manual Site Discovery

IQVISION allows you to read device data in directly from a site and manually add the required points to the database. 
This can only be achieved while IQVISION is connected to the site and involves the following steps:

▪▪ Add a Trend Driver
▪▪ Configure the Trend Driver(s)
▪▪ Discover and Add Devices from the Trend Site
▪▪ Add the Required Trend Points to the Database
▪▪ Add User-defined Points
▪▪ Add Time Schedules
▪▪ Add Trend Plots (Histories)
▪▪ Set History Update Rates for a Trend Site

If you have purchased an OPEN licence and want to use values from non-Trend systems it is necessary to connect to 
the 3rd-party systems and add the required points to IQVISION - see “10 Connect to 3rd Party Systems” on page 
47.

8.2.1	 Add a Trend Driver

A Trend Driver is required for each Trend Network (or Site) that you wish to supervise with IQVISION. These must 
be added and copied to a specific folder. The Trend driver controls the communications and flow of data to and from 
the site.

Note: On larger sites it may speed up data transfer to utilise two separate Trend drivers – one that is used for points 
and Time Schedules, and one that is dedicated to histories.

8.2.1.1	 Create a folder for Trend Drivers

1.	 In the Nav tree open the Station folder.
2.	 Open the Config folder.
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3.	 Right-click on Drivers and select New > Folder. The Name dialogue box is displayed.

4.	 Type TREND and click OK. The new folder will appear in the Nav tree.
5.	 Right-click the TREND folder and select Rename. The Rename dialogue box is displayed.

6.	 Type Trend Control Systems and click OK.

8.2.1.2	 Add the Trend Driver

1.	 In the Nav tree open the Station folder.
2.	 Open the Config folder.
3.	 Double click on Drivers. The view pane will show a list of installed Drivers (Driver Manager).
4.	 Click on the New button. The New dialogue box is displayed.

5.	 In the Type to Add box select ‘Trend Ip Network’.
6.	 Click OK. The following dialogue box is displayed.

7.	 Change the default network Name to be a meaningful name for the site. 

Note: This can be renamed later by right-clicking the driver in the Nav tree and selecting Rename.

8.	 Click OK. The Driver Manager will now show the Trend driver.

Note: The Status indicator will show ‘{down}’ as it is not yet configured/connected to the site.

9.	 Right-click the driver and select Cut.
10.	 In the Nav tree, right-click the Trend Control Systems folder (created in section 8.2.1.1 on page 31) and 

select Paste.
11.	 Repeat this process for each Trend site.
12.	 You now need to configure the communications for each Trend driver - see “Configure the Trend Driver(s)” 

on page 33.
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8.2.2	 Configure the Trend Driver(s)

IQVISION connects to the Trend network using a vCNC in a Trend device. It is necessary to configure IQVISION 
with the IP Address (or hostname) of the device with the vCNC and the port number of the vCNC. You may also need 
to change some connection settings.

Before performing this step it is recommend that you set up the vCNC in the Trend device in order that the connection 
can be tested. Refer to the relevant device documentation for details.

1.	 In the Nav tree right-click on the Trend driver (e.g. TrendIpNetwork) and choose Views > Property Sheet. 
The view pane will show a list of driver properties:

2.	 Expand the vCNC Connection Manager and n1 items.
3.	 Enter the details of the vCNC that IQVISION is to use to connect to the Trend system:

▪▪ Type the IP Address (or hostname) of the vCNC device in the Virtual CNC IP/Hostname box,  
e.g. 165.195.93.158.

▪▪ Type the port number of the vCNC in the Virtual CNC Port box, e.g. 10024.

4.	 If the vCNC is located on a site containing an IQeco, IQ1 or IQ2 controller you may need to increase the 
Response Timeout from the default of 10 s, due to the slower response times of these controllers.

5.	 Expand the Communication Profile item and change the default parameter settings if required.

Parameter Default Setting
Permanent Connection true true = permanent connection. Select if alarms are to be sent 

to the vCNC connecting IQVISION to the Trend network.
false = temporary connection.

Connection Timeout 10 s The time period before a connection attempt is considered 
to have failed. This may need to be increased when making 
remote connections over VPN.

Connection Reconnect Delay 10 s The time period before a reconnection is attempted after a 
connection timeout.

Retrys Per Connection Attempt 3 The number of reconnection attempts. This may need to be 
increased when making remote connections over VPN.

Linger Pre Disconnect 1 m On a temporary connection this sets how long the connection 
remains open after the last comms message.

6.	 Click .
7.	 Check that the Connection State changes from ‘Disconnected’ to ‘Connected’. If not, check that the IP 

Address (or hostname) and port number have been entered correctly and that the vCNC is enabled.
8.	 Repeat this process for each Trend driver.
9.	 Proceed to “Discover and Add Devices from the Trend Site” on page 34.
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8.2.3	 Discover and Add Devices from the Trend Site

1.	 In the Nav tree, open the Drivers folder and double click the Trend Driver/Site. The view pane will display 
the Trend Device Manager.

2.	 Click the Discover button. The Device Discovery dialogue box is displayed.

3.	 Choose the required option discovery option:

Choose... To Discover...
Discover ALL LANs All devices on all LANs accessible via the vCNC.
Discover a single LAN... Devices on a single specified LAN. After selecting this option a dialogue box is 

displayed requesting a valid LAN number. 

4.	 To include CNC devices in the discovery, select Show CNC Devices.
5.	 Click OK. The discovery process starts. A progress bar at the top of the pane indicates the status of the 

discovery. Once the discovery is complete the devices that have been discovered are displayed in the 
Discovered list.

Hint: During the discovery process you can click on the  button at the top right to display a Job Log giving 
details about the discovery process so far.

6.	 In the Discovered list select the device(s) from which values are required. To select more than one device hold 
down the CTRL key and click on the required devices.
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7.	 Click Add or drag the selected device(s) to the Database list. The Add dialogue box is displayed.

8.	 Review the settings for each device:

▪▪ If required, change the device name in the Name box.
▪▪ If a controller has security enabled, enter a suitable PIN in the PIN box. The PIN must correspond to 

a User Module (in the controller’s strategy) with a user level of at least 99.

If multiple devices are listed, click on the device in the list (to highlight it) to view its settings.

9.	 Click OK. You will now be asked if you want to update site alarm data:

10.	 Click Yes to start the process of learning GUIDs from IQ3 and IQ4 controllers, and MAC addresses from all 
Ethernet devices. This information is used by the alarm listener service. Scanning may take a while.

Click No to perform this process later, and go to 12 - see “Configuring Site Alarm Information” on page 
64.

If you select Yes, scanning will start. Once completed a results dialogue box is displayed goto 11. For example:

Check the results for any problems found, such as having more than one GUID or duplicate MAC addresses.

11.	 Close the dialogue box (click X). The device(s) is added to the Database and sorted in to LAN groups:

12.	 Check that the required devices have been added. Double click on a LAN to display the devices found on that 
LAN.
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8.2.4	 Add the Required Trend Points to the Database

This process allows you to add point values for Sensors, Knobs, Drivers, Switches and Digital Inputs from previously 
discovered devices. To add points for other Trend modules or parameters refer to “Add User-defined Points” on 
page 38.

1.	 In the Nav tree double click the Trend Driver/Site to open the Trend Device Manager.
2.	 Double click the required LAN. The Database list will show the previously discovered devices:

3.	 In the Exts column of the Database list double click the  icon for the required controller. The Trend Point 
Manager is displayed.

4.	 To discover only points of one type, double click the required point type (e.g. Sensors). Otherwise, to discover 
all available points, go to step 5.

5.	 Click Discover. The discovery process starts. A progress bar at the top to the pane indicates the status of the 
discovery. Once the discovery is complete, module details are displayed in the Discovered list:

 

6.	 In the Discovered list select the required points (values). To select more than one point hold down the CTRL 
key and click on the required points.

Note: Remember that IQVISION is licensed for use up to a specific number of points. It is good practice, 
therefore, to only add points that are actually required. Adding points that won’t be used by IQVISION will 
not only waste resources but also generate unnecessary extra network traffic.
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7.	 Click Add or drag the selected point(s) to the Database pane. The Add dialogue box is displayed.

Note: IQVISION automatically chooses the most suitable writable point type. However, this can be manually 
changed by selecting a point in the list and choosing a different Item Type:

Item Type Point Usage
Generic Numeric Point Numeric values, readable only
Generic Numeric Writable Numeric values, readable and writable
Generic Boolean Point Binary (on/off) values, readable only
Generic Boolean Writable Binary (on/off) values, readable and writable

8.	 Click OK. The selected point(s) is added to the Database and sorted into folders in the Nav tree.

9.	 Repeat the above process to add points for each controller.



38	 IQVISION Configuration Manual TE201382 Issue 4, 13-Feb-2017

Building a Site 

8.2.5	 Add User-defined Points

Points can be added to IQVISION for any Trend module parameter that can be accessed through Trend text comms 
as long as you know the reference for the parameter. For example, you may want to expose the high alarm value for 
a sensor. For further details on text comms codes refer to the configuration manual for the appropriate controller(s).

1.	 In the Nav tree right-click on the Trend driver and select Views > Trend Device Manager.
2.	 Double click the LAN for the required controller. The Database list will show previously discovered devices:

3.	 In the Exts column of the Database pane double click the  icon for the required controller in the list. The 
Trend Point Manager is displayed.

4.	 Double click the User Defined point type.
5.	 Click New. The following dialogue box is displayed.

6.	 In the add.type box select the option that best suits the point type:

Item Type Point Usage
Generic Numeric Point Numeric values, readable only
Generic Numeric Writable Numeric values, readable and writable
Generic Boolean Point Binary (on/off) values, readable only
Generic Boolean Writable Binary (on/off) values, readable and writable

8.	 Click OK. The following dialogue box is displayed.

9.	 In the Name box type a suitable name for the point (e.g. Sensor 1 High Alarm).
10.	 In the Trend Item Reference box type the text comms code for the required parameter (e.g. S1(H)).

Note: IQVISION does not check that the text comms reference is valid.

11.	 Click OK. The point is added to the database.
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8.2.6	 Add Time Schedules

IQVISION manages the reading and writing of Time Schedules separately. A read only ‘import’ version of the time 
schedule is used to obtain data from the controller. If times or exceptions (Special Events) only need to be viewed 
in IQVISION then this is all that is needed. However, to be able to change times or add/change exceptions (Special 
Events) a second editable ‘export’ version of the time schedule must be created.

1.	 In the Nav tree double click the Trend Driver/Site to open the Trend Device Manager.
2.	 Double click the required LAN. The Database list will show the previously discovered devices:

3.	 In the Exts column of the Database list double click the  icon for the required controller. The Trend 
Schedule Import Manager is displayed.

4.	 Click Discover. Any Time Schedules in the controller will appear in the Discovered list: 

5.	 Select the required time schedule(s) and click Add. The Add dialogue box is displayed. 

6.	 Click OK.
7.	 In the Nav tree right-click Schedules and choose Views > Trend Schedule Export Manager.
8.	 Click Discover. Any Time Schedules in the controller will appear in the Discovered list.
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9.	 Select the required time schedule(s) and click Add. The Add dialogue box is displayed.

10.	 Click OK.
11.	 Open the Schedules folder. You will see both an ‘Import’ and ‘Export’ version of the time schedule.
12.	 Double click the read-only ‘Import’ schedule view to check times have been collected from the controller:

For simple systems the export version of the time schedule can be used to make changes to controller’s occupation 
times or set up Special Events (exceptions). See “Viewing and Changing Occupation Times (Time Schedules)” 
on page 110.

For more complex occupation requirements see “Controlling Complex Occupation Times” on page 53.
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8.2.7	 Add Trend Plots (Histories)

Plot records held in Trend controllers can be downloaded into an IQVISION history and used for displaying graphs 
of measured values.

By default, data is collected from a plot module once daily at 02:00:00 AM GMT. This can be altered as required 
for each history, and must be altered for plots with intervals of 1 second or 1 minute to prevent data being lost. For 
example, assuming a plot module maintains a maximum of 1000 plot records, 1 second plots must be collected at 
least once every 16 minutes, and 1 minute plots must be collected at least once every 16 hours.

1.	 In the Nav tree double click the Trend Driver/Site to open the Trend Device Manager.

Note: To speed up data transfer larger sites may utilise two separate Trend drivers – one that is used for points 
and Time Schedules, and one that is dedicated to histories. Ensure that the correct driver is selected.

2.	 Double click the required LAN. The Database list will show the previously discovered devices:

3.	 In the Exts column of the Database list double click the  icon for the required controller. The Trend 
History Import Manager is displayed.

4.	 Click Discover. Any plot modules in the controller will appear in the Discovered pane:

5.	 In the Discovered pane select the required plots. To select more than one plot hold down the CTRL key and 
click on the required plots.
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6.	 Click Add or drag the selected plot(s) to the Database pane. The Add dialogue box is displayed.

IMPORTANT: The Execution Time (i.e. the time when data is collected from the plot module) defaults to once 
daily at 02:00:00 AM GMT.

7.	 Select a plot module from the list and check its Interval time.
8.	 Change the settings for Execution Time to ensure that data is collected at a suitable interval, to prevent data 

loss. For example, 1 second plots must be collected at least once every 16 minutes, and 1 minute plots must be 
collected at least once every 16 hours. 

9.	 Specify the capacity of the plot. The capacity specifies the number of values recorded before the first is 
overridden and defaults to 100,000.

Note: Ensure the plot data is backed up before it is overridden.

10.	 Repeat steps 7, 8 and 9 for each plot in the list.
11.	 Click OK. The selected plot(s) is added to the Database pane.
12.	 If required, repeat the above process to add plots for each of the other controllers.

Note: After adding a history, data will not be collected from the controller until its next scheduled execution 
time, You can force data collection by using the Archive function - see “Using the Archive Function” on 
page 44.
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8.2.8	 Set History Update Rates for a Trend Site

In order to minimise network traffic and, therefore, reduce potential latency, it is important to correctly configure 
histories for viewing live updates. This may required adjustment of the various history update rates for each Trend 
network.

1.	 In the Nav tree right-click the Trend driver and select Views > Property Sheet. The driver’s properties is 
displayed in the view pane.

2.	 Expand the History Network Ext item and then expand the On Demand Poll Scheduler item.

3.	 Adjust the values for Fast Rate, Normal Rate and Slow Rate to a minimum of 15 minutes, in order to avoid 
network communications saturation.

4.	 Click Save at the bottom of the screen.

IMPORTANT: Repeat this procedure for each Trend network.
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8.2.8.1	 Using the Archive Function

Histories only collect new data from a controller at their scheduled execution time. You can force data collection at 
any time by using the Archive function.

1.	 Open the Trend History Import Manager - see “Add Trend Plots (Histories)” on page 41.
2.	 Click Archive to force a download to all histories in the database.
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9	 CONNECT TO TONNS

If you have purchased a licence that enables you to use points from a TONN it is necessary to add the TONN to the 
Niagara network, and then add the required points to the IQVISION database.

The following steps are required to connect to a TONN:

▪▪ Licence with an N licence - see “Licensing IQVISION” on page 23.
▪▪ Add the TONNs to the Niagara Network
▪▪ Add TONN Points to the Database

9.1	 Add the TONNs to the Niagara Network

1.	 In the Nav tree, open the Drivers folder and double click NiagaraNetwork. The view pane will display the 
Station Manager.

2.	 Click the Discover button. The discovery process starts. A progress bar at the top of the pane indicates the 
status of the discovery. Once the discovery is complete the devices that have been discovered are displayed 
in the Discovered list.

Hint: During the discovery process you can click on the  button at the top right to display a Job Log giving 
details about the discovery process so far.

3.	 In the Discovered list select the TONN(s) from which values are required. To select more than one device hold 
down the CTRL key and click on the required devices.

Note: The licence will restrict the number of TONNs that can be used.

4.	 Click Add or drag the selected device(s) to the Database list. The Add dialogue box is displayed.
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5.	 Review the settings for each device:

▪▪ If required, change the device name in the Name box.

If multiple devices are listed, click on the device in the list (to highlight it) to view its settings.

6.	 Click OK.

9.2	 Add TONN Points to the Database

This process allows you to add points from previously discovered TONNs.

1.	 In the Nav tree, open the Drivers folder and double click NiagaraNetwork The view pane will display the 
Station Manager.

2.	 In the Exts column of the Database list double click the required icon for the required TONN. The Niagara 
Points Manager is displayed.

3.	 In the Discovered list select the required points (values). To select more than one point hold down the CTRL 
key and click on the required points.

Note: Remember that IQVISION is licensed for use up to a specific number of points. It is good practice, 
therefore, to only add points that are actually required. Adding points that won’t be used by IQVISION will 
not only waste resources but also generate unnecessary extra network traffic.

4.	 Click Add or drag the selected point(s) to the Database pane. The Add dialogue box is displayed.

Note: IQVISION automatically chooses the most suitable writable point type. However, this can be manually 
changed by selecting a point in the list and choosing a different Item Type.

5.	 Click OK. The selected point(s) is added to the database. 
6.	 Repeat the above process to add points for each TONN.
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10	 CONNECT TO 3RD PARTY SYSTEMS

If you have purchased an OPEN licence and want to use values from non-Trend systems it is necessary to connect to 
the 3rd-party systems and add the required points to the IQVISION database.

The following steps are required to connect to 3rd party systems:

▪▪ Licence with an OPEN licence - see “Licensing IQVISION” on page 23.
▪▪ Add the Required 3rd Party Drivers
▪▪ Configure 3rd Party Drivers
▪▪ Add 3rd Party Points to the Database

Note: For detail of using the BACnet Driver see “Using the BACnet Driver” on page 48.

10.1	 Add the Required 3rd Party Drivers

1.	 In the Nav tree open the Station folder.
2.	 Open the Config folder.
3.	 Double click on Drivers. The view pane will show a list of installed Drivers (Driver Manager).
4.	 Click on the New button. The New dialogue box is displayed.

5.	 In the Type to Add box select the required driver, e.g. ‘BacnetNetwork’.
6.	 Click OK. The following dialogue box is displayed.

7.	 Change the default network Name to be a meaningful name.

Note: This can be renamed later by right-clicking the driver in the Nav tree and selecting Rename.

8.	 Click OK. The Driver Manager will now show the driver.

9.	 You now need to configure the driver - see “Configure 3rd Party Drivers” on page 47.

10.2	 Configure 3rd Party Drivers

The configuration of each 3rd party driver is different, refer to the Tridium documentation for the driver for details.

10.3	 Add 3rd Party Points to the Database

The method of adding points to the database for each 3rd party driver is different, refer to the Tridium documentation 
for the driver for details.



48	 IQVISION Configuration Manual TE201382 Issue 4, 13-Feb-2017

Connect to 3rd Party Systems 

10.4	 Using the BACnet Driver

The ability to use values from a BACnet system is quite common and is supported by IQVISION. This section provides 
an overview of how to use the BACnet driver with IQVISION. For full details refer to the Tridium documentation.

The following steps are required to connect to a BACnet system:

▪▪ Licence with an OPEN licence - see “Licensing IQVISION” on page 23.
▪▪ Add the BACnet Driver
▪▪ Configure the BACnet Driver
▪▪ Discover and Add BACnet Devices
▪▪ Add the Required BACnet Points to the Database

10.4.1	 Add the BACnet Driver

Follow the procedure described in “Add the Required 3rd Party Drivers” on page 47 to add the BACnet driver.

▪▪ In step 5 in the Type to Add box select ‘BacnetNetwork’.
▪▪ If required the BACnet driver can be renamed as it is being added. This can be useful if dealing with 

several BACnet installations.

10.4.2	 Configure the BACnet Driver

1.	 In the Nav tree open the Station folder.
2.	 Open the Config folder.
3.	 Double click on Drivers. The view pane will show a list of installed Drivers (Driver Manager).
4.	 In the Nav tree open the folder for the BACnet driver (BacnetNetwork) and double click Local Device.
5.	 Set the Object Id to the IQVISION’s address on the BACnet network (range 1-4194302).

6.	 In the Nav tree open the Bacnet Comm folder and double click Network and expand the Ip port section.

7.	 Set the Network Number to 1. 
8.	 Set Enabled to true.
9.	 Click .
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10.4.3	 Discover and Add BACnet Devices

1.	 In the Nav tree, open the Drivers folder and double click the BACnet driver. The view pane will display the 
Bacnet Device Manager.

2.	 Click Discover. The Configure Device Discovery dialogue box is displayed.

3.	 If the address range of controllers is known then the Device Low Limit and Device High Limit can be edited 
to reduce discovery time.

4.	 Click OK. The discovery process starts. A progress bar at the top of the pane indicates the status of the 
discovery. Once the discovery is complete the devices that have been discovered are displayed in the 
Discovered list.

Hint: During the discovery process you can click on the  button at the top right to display a Job Log giving 
details about the discovery process so far.

5.	 In the Discovered list select the device(s) from which values are required. To select more than one device hold 
down the CTRL key and click on the required devices.

Hint: The discovery will also find Trend deivces that have BACnet compatibility. In order to easily identify 
these devices sort the list by Vendor by clicking on the Vendor column.

6.	 Click Add or drag the selected device(s) to the Database list. The Add dialogue box is displayed.
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7.	 Review the settings for each device:

▪▪ If required, change the device name in the Name box.

If multiple devices are listed, click on the device in the list (to highlight it) to view its settings.

8.	 Check that the required devices have been added.

10.4.4	 Add the Required BACnet Points to the Database

This process allows you to add points, alarm configuration, schedules and histories from previously discovered 
devices.

1.	 In the Nav tree, open the Drivers folder and double click the BACnet driver. The view pane will display the 
Bacnet Device Manager.

2.	 In the Exts column of the Database list double click the required icon.

 = Points
 = Alarm Configuration
 = Schedules
 = Histories

The BACnet Point Manager is displayed.

3.	 Click Discover. The discovery process starts. A progress bar at the top to the pane indicates the status of the 
discovery. Once the discovery is complete, points are displayed in the Discovered list:

 

4.	 In the Discovered list select the required points (values). To select more than one point hold down the CTRL 
key and click on the required points.

Note: Remember that IQVISION is licensed for use up to a specific number of points. It is good practice, 
therefore, to only add points that are actually required. Adding points that won’t be used by IQVISION will 
not only waste resources but also generate unnecessary extra network traffic.
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5.	 Click Add or drag the selected point(s) to the Database pane. The Add dialogue box is displayed.

Note: IQVISION automatically chooses the most suitable writable point type. However, this can be manually 
changed by selecting a point in the list and choosing a different Item Type.

6.	 Click OK. The selected point(s) is added to the database. 
7.	 Repeat the above process to add points for each controller.
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11	 CONTROLLING COMPLEX OCCUPATION TIMES

As described in “Add Time Schedules” on page 39 a read only ‘import’ version of the time schedule is used to 
obtain data from the controller and a second editable ‘export’ version of the time schedule allows times to be written 
to IQ controllers.

For simple systems the export version of the time schedule can be used to make changes to controller’s occupation 
times or set up Special Events (exceptions). See “Viewing and Changing Occupation Times (Time Schedules)” 
on page 110.

For more complex occupation requirements the occupation times can be controlled centrally.

11.1	 Control Occupation Times Centrally

For sites with a number of Time Schedules in different controllers the occupation times can be controlled centrally 
to reduce the time taken to make changes. To enable this a BooleanSchedule should be added for each group of Time 
Schedules in the Trend controllers that are to operate the same times e.g. one for office occupation time and another 
for factory occupation and each of the Time Schedules linked to the BooleanSchedule. The occupation times for 
those Time Schedules are then specified in the BooleanSchedule.

A CalendarSchedule can be added to enable central control of days that operate different times e.g. for bank holidays 
- see “Using a CalendarSchedule” on page 58.

The following steps are required to configure IQVISION to control occupation times centrally:

Create a Folder for the Master Time Schedules
Add a BooleanSchedule
Break Link with Schedule Import
Link the Time Schedules to the BooleanSchedule
Set the Weekly Schedule
Set the Special Events (Exceptions)

See “Controlling Occupation Times Centrally” on page 113 for detail of change occupation times centrally.

11.1.1	 Create a Folder for the Master Time Schedules

It is recommend that a folder is created to store the information required to control the occupation times.

1.	 In the Nav tree open My Host > Station(IQVISION).
2.	 Right click Config and select New > Folder. The Name dialogue box is displayed.

3.	 Specify the folder’s name e.g. ‘Master Time Schedules’.
4.	 Click OK.
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11.1.2	 Add a BooleanSchedule

A BooleanSchedule must be added for each group of Time Schedules in the Trend controllers that are to operate the 
same times.

1.	 In the Nav tree open My Host > Station(IQVISION), navigate to the folder created for the master Time 
Schedules and double click to display the wire sheet in the view pane.

2.	 Open the schedule palette - see “Palettes” on page 106. 
3.	 Drag a BooleanSchedule onto the wire sheet. The Name box is displayed.

4.	 Enter a name for the BooleanSchedule. This should reflect the times it is to control e.g. ‘OfficeOccupation’.
5.	 Click OK.

11.1.3	 Break Link with Schedule Import

The link between an export schedule and the corresponding import schedule must be broken for each of the Time 
Schedules that are to be centrally controlled.

1.	 In the Nav tree open My Host > Station(IQVISION), navigate to the controller containing the time schedule 
that is to be unlinked.

2.	 In the Nav tree right-click Schedules and choose Views > Trend Schedule Export Manager.
3.	 Double click the time schedule that is to be unlinked. The Edit dialogue box is displayed.

4.	 In the Match Schedule Import box select false.
5.	 Click OK.
6.	 Repeat for all required Time Schedules.



IQVISION Configuration Manual TE201382 Issue 4, 13-Feb-2017� 55

Controlling Complex Occupation Times

11.1.4	 Link the Time Schedules to the BooleanSchedule

Each of the Time Schedules that are to be controlled must be linked to the BooleanSchedule.

1.	 In the Nav tree open My Host > Station(IQVISION), navigate to the controller containing the time schedule 
that is to be unlinked.

2.	 In the Nav tree right-click Schedules and choose Views > Trend Schedule Export Manager.
3.	 Double click the time schedule that is to be linked to the BooleanSchedule. The Edit dialogue box is displayed.

4.	 In the Supervisor Ord box select the required BooleanSchedule.
5.	 Click OK.
6.	 Repeat for all required Time Schedules.

11.1.5	 Set the Weekly Schedule

The Weekly Schedule determines the occupation times for a normal week i.e. no Special Events apply.

1.	 In the Nav tree open My Host > Station(IQVISION), navigate to the required BooleanSchedule.
2.	 Double click the BooleanSchedule. The Scheduler is displayed in the view pane.

3.	 Select the Weekly Schedule tab.
4.	 Specify the required occupation times:

▪▪ To add a new time period: Drag the mouse in the required white area of the grid.
▪▪ To make adjustments to existing time periods: Drag the top or bottom edge of the green rectangles 

to the required time. 
▪▪ To set all day occupation: Right click the day and select All Day Event.
▪▪ To apply a day’s times Monday to Friday: Right click the day and select Apply M-F.
▪▪ To remove a time period: Right-click the rectangle and select Delete Event.
▪▪ To remove all time periods for a day: Right click the day and select Clear Day.
▪▪ To copy a day: Right click the day and select Copy Day then right click the day the times are to be 

copied to and select Paste Day.

5.	 Click Save.
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11.1.6	 Set the Special Events (Exceptions)

Special Events enable different occupation times to be used on specific days.

1.	 In the Nav tree open My Host > Station(IQVISION), navigate to the required BooleanSchedule.
2.	 Double click the BooleanSchedule. The Scheduler is displayed in the view pane.
3.	 Select the Special Events tab.

4.	 Specify the required Special Events:

Add a Special Event
▪▪ Click Add. The Add dialogue box is displayed.

▪▪ Specify a name for the Special Event in the Name box.
▪▪ Select Date or Date Range in the Type box.

Do NOT select any of the other options in the Type box as they are not supported by the controller 
and will cause problems.

▪▪ Specify the date(s) the Special Event applies to:

▪▪ Date: Specify the day month and year in the appropriate box.
▪▪ Date Range: Specify the day month and year for the beginning of the range in the appropriate box 

in the top row and specify the day month and year for the end of the range in the appropriate box in 
the bottom row.

▪▪ Click OK.
▪▪ Edit the times - see “Edit the times” on page 57.
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Edit the times
▪▪ Click the Special Event for which the times are to be edited.

▪▪ To add a new time period: Drag the mouse in the required white area of the grid.
▪▪ To make adjustments to existing time periods: Drag the top or bottom edge of the green rectangles 

to the required time. 
▪▪ To set all day occupation: Right click the day and select All Day Event.
▪▪ To remove a time period: Right-click the rectangle and select Delete Event.
▪▪ To remove all time periods: Right click the day and select Clear Day.

▪▪ To ensure non-occupancy outside the specified periods right click the day and select Schedule Defaults.

Rename a Special Event
▪▪ Right click the Special Event that is to be renamed.
▪▪ Click Rename. The Rename dialogue box is displayed.

▪▪ Enter the new name.
▪▪ Click OK.

Delete a Special Event
▪▪ Right click the Special Event that is to be deleted.
▪▪ Click Delete. The Confirm dialogue box is displayed.

▪▪ Click Yes.

5.	 Click Save.
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11.2	 Using a CalendarSchedule

Time Schedules that are controlled by a BooleanSchedule will, by default, use occupation times specified in the 
Weekly Schedule. A CalendarSchedule can be used to specify days which will use different times, e.g. Bank Holidays.

CalendarSchedules only specify the dates where times are different; the times worked on these days are specified in 
the BooleanSchedule. This allows different areas to work different times.

The following steps are required to configure IQVISION to use a CalendarSchedule:

Configure IQVISION to control occupation times centrally - see “Control Occupation Times Centrally” 
on page 53.
Add a CalendarSchedule
Link a CalendarSchedule to a BooleanSchedule
Specify the Dates
Specify the Occupation Times

11.2.1	 Add a CalendarSchedule

1.	 In the Nav tree open My Host > Station(IQVISION), navigate to the folder created for the Master Time 
Schedules and double click to display the wire sheet in the view pane.

2.	 Open the schedule palette - see “Palettes” on page 106. 
3.	 Drag a CalendarSchedule onto the wire sheet. The Name dialogue box is displayed.

4.	 Enter a name for the CalendarSchedule. This should reflect the times it is to control e.g. ‘BankHolidays’.
5.	 Click OK.

11.2.2	 Link a CalendarSchedule to a BooleanSchedule

Each BooleanSchedule that is to use different times on the dates specified by the CalendarSchedule must be linked 
to the CalendarSchedule.

1.	 In the Nav tree open My Host > Station(IQVISION), navigate to the required BooleanSchedule.
2.	 Double click the BooleanSchedule. The Scheduler is displayed in the view pane.
3.	 Select the Special Events tab.
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4.	 Click Add. The Add dialogue box is displayed.

5.	 Specify a name for the Special Event in the Name box.
6.	 Select Reference in the Type box. The CalendarSchedule should appear in the dialogue box.

7.	 Click OK. A Special Event that will use the dates specified by the CalendarSchedule is added to the 
BooleanSchedule. Currently no times are specified.
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11.2.3	 Specify the Occupation Times

The times used on the dates specified by the CalendarSchedule must be specified.

1.	 In the Nav tree open My Host > Station(IQVISION), navigate to the required BooleanSchedule.
2.	 Double click the BooleanSchedule. The Scheduler is displayed in the view pane.
3.	 Select the Special Events tab.

4.	 Select the Special Event for which times are to be specified.
5.	 Specify the occupation times for the Special Event:

▪▪ To add a new time period: Drag the mouse in the required white area of the grid.
▪▪ To make adjustments to existing time periods: Drag the top or bottom edge of the green rectangles 

to the required time. 
▪▪ To set all day occupation: Right click the day and select All Day Event.
▪▪ To remove a time period: Right click the rectangle and select Delete Event.
▪▪ To remove all time periods: Right click the day and select Clear Day.

6.	 To ensure non-occupancy outside the specified periods right click the day and select Schedule Defaults.
7.	 Click Save.
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11.2.4	 Specify the Dates

The dates that are to operate different times must be specified in the CalendarSchedule. 

1.	 In the Nav tree open My Host > Station(IQVISION), navigate to the folder created for the Master Time 
Schedules and double click to display the wire sheet in the view pane.

2.	 Double click the CalendarSchedule. The Calendar Scheduler is displayed in the view pane.

3.	 Specify the required dates:

Add a date
▪▪ Click Add. The Add dialogue box is displayed.

▪▪ Specify a name for the Special Event in the Name box.
▪▪ Select Date or Date Range in the Type box.

Do NOT select any of the other options in the Type box as they are not supported by the controller 
and will cause problems.

▪▪ Specify the date(s) the Special Event applies to:

▪▪ Date: Specify the day month and year in the appropriate box.
▪▪ Date Range: Specify the day month and year for the beginning of the range in the appropriate box 

in the top row and specify the day month and year for the end of the range in the appropriate box in 
the bottom row

▪▪ Click OK.

Edit a date
▪▪ Double click the date that is to be edited. 
▪▪ Edit the date as required.

Rename a date
▪▪ Right click the date that is to be renamed.
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▪▪ Click Rename. The Rename dialogue box is displayed.

▪▪ Enter the new name.
▪▪ Click OK.

Delete a date
▪▪ Right click the date that is to be deleted
▪▪ Click Delete. The Confirm dialogue box is displayed.

▪▪ Click Yes.

4.	 Click Save.
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12	 CONFIGURING ALARMS

Alarms generated within a Trend system can be sent to IQVISION by the following routes:

▪▪ Alarms can be sent to a specific IP address (which would be the IP Address of the PC running 
IQVISION).

▪▪ Alarms can be sent to the vCNC that IQVISION uses to connect to the site. This is only suitable if the 
IQVISION uses a permanent connection.

PC Ethernet Port

Trend Site 1

Trend Site 2

Alarm

Alarm

Trend Ip Alarm Listener

Alarm associated

with site 1

Yes

Yes

No

No
Alarm associated

with site 2

Match with

GUIDs or Device

MAC Addresses

for site 1?

Match with

GUIDs or Device

MAC Addresses

for site 2?

Alarm associated

with alarm listener

Listening Port:

2774

IP Address:

165.195.101.123

vCNC

vCNC

Alarms received via the site’s vCNC will automatically be associated with that site. 

However, alarms received via the IP Address are processed by the Trend IP Alarm Listener, which ‘listens’ for alarm 
messages on a specific port (default is 2774). It uses information obtained during device discovery to determine 
which site originated the alarm. It does this by trying to match data within the alarm message with a site GUID or 
device MAC address in the IQVISION database.

If alarms are received from unknown GUIDs or MAC addresses they will be raised against the Trend IP Alarm 
Listener service itself. 

Once an alarm is associated with a site the Alarm Service allows alarms to be assigned to different alarm classes 
which in turn allows them to be handled differently according to specific criteria. By default all alarms are assigned 
to the Default Alarm Class. Additional Classes can be added as required.

12.1	 Alarm Priorities

IQVISION can set different priorities for the various stages of alarms. The following stages exist in IQVISION:

▪▪ toOffnormal	i.e. value is valid but has gone above or below a specified level (e.g. equivalent to HIGH 
or LOW in a Trend system);

▪▪ toFault	 i.e. value is invalid such as caused by a hardware fault (e.g. equivalent to OUTL in a 
Trend system);

▪▪ toNormal 	 i.e. value is back within a normal valid range (e.g. equivalent to Alarm Cleared).

Each stage can be set to a priority level between 0 (lowest) and 255 (highest).

Escalation can be configured so that if an alarm isn’t actioned within a specified time it can be sent to a secondary 
destination(s).

The total alarm count and ‘unacked’ (unacknowledged) alarms are viewable. But individual alarms cannot be viewed 
until a recipient has been configured.
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12.2	 Setting up Alarm Handling

In order to set up alarm handling the following steps are required:

Changing the Alarm Listener Port Number
Configuring Site Alarm Information
Set up Controller Alarm Destination Modules
Adding Alarm Classes
Set the Alarm Class for an Alarm
Add an Alarm Recipient

12.2.1	 Changing the Alarm Listener Port Number

If you do not want to use the default port number (2774) to listen for IP alarms it can be changed as follows:

1.	 In the Nav tree open the Services folder (under Station > Config).
2.	 Double click TrendIpAlarmListener. The following properties will be displayed.

3.	 Change the Listening Port number as required.
4.	 Click Save.

12.2.2	 Configuring Site Alarm Information

If you choose not to scan the site for alarm information during device discovery, you will need to configure this 
information before IQVISION can associate alarms with the appropriate Trend site. This can be done either by 
scanning the site or entering the information manually.

1.	 In the Nav tree double click the Trend network driver to open the Trend Device Manager.
2.	 Click the Configure Site Alarm Information button. The following dialogue box is displayed.

To perform an automatic setup:
1.	 Click Automatic system scan setup. Scanning will commence - this may take a while. Once completed a 

results dialogue box is displayed. For example.

2.	 Check the results for any problems found such as having more than one GUID or duplicate MAC addresses.
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To perform a manual setup:
1.	 Click Manual entry of GUID/MAC address for Site. The following dialogue box is displayed.

2.	 Type in a valid Site GUID and/or the MAC Address of the device that is forwarding alarms from the site.
3.	 Click the Update button.

12.2.3	 Set up Controller Alarm Destination Modules

Controllers send alarms to the destination specified by one or more Alarm Destination modules in their strategy. For 
alarms to be sent to the IP Address of IQVISION, configure the module as follows:

Destination Type:	 IP.
Destination:		  The IP address of the IQVISION PC.
Dest. Port:		  The alarm listening port (typically 2774).

For alarms to be sent via the vCNC to IQVISION, configure the module as follows:

Destination Type:	 IQ Lan
Alarm Address:	 The address of the vCNC on the Trend network.
Remote Lan:		  The LAN number of the vCNC on the Trend network.

Note: A permanent vCNC connection is required for alarms to be sent this way.	

Refer to the IQSET Manual (TE200147) for further details on setting up controller Alarm Destination modules.

12.2.4	 Adding Alarm Classes

The Alarm Service allows alarms to be assigned to different alarm classes which in turn allows them to be handled 
differently according to specific criteria. By default all alarms are assigned to the Default Alarm Class. Additional 
Classes can be added as required.

To add an alarm class
1.	 In the Nav tree open the Station > Config > Services folder.
2.	 Double click AlarmService. The view pane will display the Alarm Service wire sheet.

3.	 Open the Alarm Palette  - see “Palettes” on page 106.
4.	 Drag an AlarmClass item onto the wire sheet. The Name dialogue box is displayed.
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5.	 Change the default class name as required (e.g. Critical Alarms) and click OK.

12.2.5	 Set the Alarm Class for an Alarm

By default all alarms are assigned to the Default Alarm Class. If you have added other Alarm Classes you need to 
specify which class each alarm is to use.

To set the class for an alarm:
1.	 In the Nav tree drill down into the required site and locate the Alarm Info item for the required point (e.g. a 

Sensor).

2.	 Double click the Alarm Info item to display the Property Sheet in the view pane.

3.	 Pick the required Alarm Class from the drop-down list.

Note: To add further alarm classes to the list refer to “Adding Alarm Classes” on page 65.
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12.2.6	 Add an Alarm Recipient

For alarms to be seen by a user they must be passed to a recipient. This will most commonly be a Console Recipient 
which allows alarms to be listed and acted upon. There is also a Station Recipient which allows alarms to be passed 
to another instance of IQVISION.

To add an alarm recipient:
1.	 In the Nav tree open the Station > Config > Services folder.
2.	 Double click AlarmService. The view pane will display the Alarm Service wire sheet.

3.	 Open the Alarm Palette (see “Palettes” on page 106) and open the Recipients folder.
4.	 Drag a ConsoleRecipient item onto the Wire Sheet. The Name dialogue box is displayed.

5.	 Change the default name as required (e.g. AlarmConsole) and click OK. The recipient is added to the wire 
sheet.

6.	 Position the mouse pointer on the right-hand side of the Alarm item in AlarmClass and drag to the left-hand 
side of the RouteAlarm item in the ConsoleRecipient.

Note: Multiple AlarmClass items can be linked to the same ConsoleRecipient if required.

7.	 To check correct setup, double click the ConsoleRecipient. The Alarm Console will display in the view pane.
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13	 CREATING SCHEMATICS (PX Pages)

Schematics within IQVISION are known as PX Pages (Presentation XML).

Existing schematic pages can be imported/migrated into IQVISION from another supervisor (e.g. 963) using the 
Migration Tool - see section “Migration Tool” on page 95. Once migrated you can make changes to the PX Pages 
using the various tools within IQVISION. The same tools may also be used to create new PX Pages from scratch.

This section describes how to create the most commonly required features of PX Pages. For more in depth information 
please refer to the Tridium documentation.

It is recommended that you create a template page that contains features that are needed on each page, e.g. a logo, 
outside temperature, navigation buttons, etc. It is also recommended that you create a folder to store all the PX Pages, 
and another folder to store any images used on the pages.

The following steps are required to create PX Pages:

Create a Folder for the PX Pages
Create a Folder for the Images
Prepare Images
Add Images to IQVISION
Specify the PX Template Page
Create a PX Page
Edit a PX Page

13.1	 Create a Folder for the PX Pages

PX Pages can be created at any point within IQVISION e.g. added to a folder, device or a module. However, this can 
make engineering unnecessarily complicated so it is recommend that a folder is created to contain them.

1.	 In the Nav tree open My Host > Station(IQVISION).
2.	 Right click Config and select New> Folder. The Name dialogue box is displayed.

3.	 Specify the folders’s name e.g. ‘Schematics’.
4.	 Click OK.

13.2	 Create a Folder for the Images

1.	 In the Nav tree open My Host > Station(IQVISION).
2.	 Right click Files and select New> Folder. The Name dialogue box is displayed.

3.	 Specify the folders’s name e.g. ‘Images’.
4.	 Click OK.

13.3	 Prepare Images

Any external images that are to be used on PX Pages must be created using a 3rd party graphics package and sized 
to the size required on the PX Pages.

Note: Once the images have been added to IQVISION they cannot be changed.
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13.4	 Add Images to IQVISION

To use images within IQVISION they must exist within the file structure of IQVISION.

1.	 In the Nav tree open My Host > My File System and navigate to the file that is to be added (this could be a 
folder containing multiple graphics).

2.	 Right click the file or folder and select Copy.
3.	 In the Nav tree open My Host > Station(IQVISION) > Files and navigate to the location the image(s) are to 

be stored e.g. the folder created in Create a Folder for the Images.
4.	 Right click the location (e.g. images) and select Paste.

13.5	 Specify the PX Template Page

PX Pages are created using the template PX Page (located - My Host > Sys Home > defaults > workbench > newfiles 
> PxFile.px). By editing this page all future PX Pages created will have this format.

1.	 In the Nav tree open My Host > My File System > Sys Home > defaults > workbench > newfiles.
2.	 Double click the PxFile.px file.
3.	 On the menu bar click the  icon to switch to PX Editor view.

Note: The grid in the middle of the screen is the viewable area of the page. 

4.	 Design the page layout as required - see “Create or Change PX Page Elements” on page 71.
5.	 Save the file (select File> Save, or press CTRL+S).



IQVISION Configuration Manual TE201382 Issue 4, 13-Feb-2017� 71

Creating Schematics (PX Pages)

13.6	 Create a PX Page

PX Pages are created by making a new view of an element in the Nav tree and once a PX view is added it is the new 
default view of the element. PX Pages are stored in the IQVISION file structure, but are linked to the element where 
the view has been attached.

To keep structure simple it is a good idea to create subfolders. These subfolders hold the various schematics you want 
to create.

1.	 In the Nav tree open My Host > Station(IQVISION) > Config and navigate to where the PX Page is to be 
located e.g. the folder created in Create a Folder for the PX Pages.

2.	 Right click the folder and select New> Folder. The Name dialogue box is displayed.

3.	 Specify the page’s name e.g. ‘Floor 4’.
4.	 Click OK a folder is created.
5.	 Right click the folder you have just created and select Views > New View. The New Px View dialogue box is 

displayed.

6.	 Enter the name of the page (same as the folder just created) in the View Name box.
7.	 Click OK. The PX Page will be created based on the template page.

13.7	 Edit a PX Page

The PX Editor is used to edit a PX Page.

1.	 In the Nav tree locate the PX file and double click on it.
2.	 On the menu bar click the  icon to switch to PX Editor view.
3.	 Change the page layout as required - see “Create or Change PX Page Elements” on page 71.
4.	 Save the file (select File> Save, or press CTRL+S).

13.7.1	 Create or Change PX Page Elements

After creating a new PX Page or opening an existing page for editing use the following procedures to design the page 
layout and content.

13.7.1.1	 Setting the Page Size and Background

To set the viewable area size:
1.	 Double click the layout grid to open the Properties dialogue box.
2.	 Click viewSize to set the visible screen size in pixels (maximum 10000 x 10000).
3.	 Click OK.

To set the background colour:
1.	 Double click the layout grid to open the Properties dialogue box.
2.	 Click the background as required and select either Solid or Gradient and use the colour picker to set the 

required colour(s).
3.	 Click OK.
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To set the background image:
1.	 Double click the layout grid to open the Properties dialogue box.
2.	 Click the background as required and select Image.
3.	 Select the required image file and alignment settings.
4.	 Click OK.

13.7.1.2	 Add Text

1.	 Right click the page and select New > Label. A label is added to the page.
2.	 Double click the label. The Properties dialogue box is displayed.

3.	 Enter the required text in the text box.
4.	 Click OK.

13.7.1.3	 Add an Image

Add your own image:
Images are sized on the screen based on their native dimensions (pixel size) - you cannot scale the image. Therefore, 
you may need to resize the image using your preferred graphics editor before adding to the page.

1.	 Navigate to the required image using the Nav tree.

Note: It is recommended that any images you intend using in IQVISION are first copied into a folder within 
the Station - see “Create a Folder for the Images” on page 69. 

2.	 Click and drag the file to the layout grid and position as required.

Note: As you drag the item on the page two green lines indicate the top left corner where the item will be 
positioned.

Add an IQVISION Image:
IQVISION has some built in images that can be added to a PX Page.

1.	 Open the palette containing the required graphics - see “Palettes” on page 106. The following palettes 
contains useful images, but there are others available:

KitPx – Covers elements like – logoff, buttons etc
KitPxHvac – has a library of various hardware graphics – pumps, boilers etc
KitPxN4svg – is similar to KitPx but all the graphics are SVG (scalable vector graphics)

2.	 Navigate to the required image using the palette.
3.	 Click and drag the image to the layout grid and position as required.

Note: As you drag the item on the page two green lines indicate the top left corner where the item will be 
positioned.
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13.7.1.4	 Add a Dynamic Object (Value)

1.	 Navigate to the required value using the Nav tree.
2.	 Click and drag the value to the layout grid and position as required.

Note: As you drag the item on the page two green lines indicate the top left corner where the item will be 
positioned.

3.	 When you release the mouse button the Make Widget dialogue box is displayed.
4.	 Select Bound Label.

5.	 Select Format Text and choose %out.Value% to display the value.
6.	 Select Make Display Name Label to display the label.
7.	 Click OK.
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13.7.1.5	 Add an Animated Image

IQVISION has some built in images that can be animated depending on value from the system.

1.	 Navigate to the value that is to be linked to the image using the Nav tree.
2.	 Click and drag the value to the layout grid and position as required.

Note: As you drag the item on the page two green lines indicate the top left corner where the item will be 
positioned.

3.	 When you release the mouse button the Make Widget dialogue box is displayed.
4.	 Select From Palette.

5.	 Open the palette containing the required graphics - see “Palettes” on page 106. 
6.	 Navigate to the required image using the palette.
7.	 Select the required image.
8.	 Click OK.
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13.7.1.6	 Add a Slider

A slider can be added to enable an analogue value to be adjusted.

1.	 Navigate to the value that is to be linked to the slider using the Nav tree.
2.	 Click and drag the value to the layout grid and position as required.

Note: As you drag the item on the page two green lines indicate the top left corner where the item will be 
positioned.

3.	 When you release the mouse button the Make Widget dialogue box is displayed.
4.	 Select From Palette.

5.	 Open the KitPx palette - see “Palettes” on page 106.
6.	 Select SetPointSlider.
7.	 Click OK.
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13.7.1.7	 Add a Button to Adjust a Value

1.	 Navigate to the value that is to be adjusted using the Nav tree.
2.	 Click and drag the value to the layout grid and position as required.

Note: As you drag the item on the page two green lines indicate the top left corner where the item will be 
positioned.

3.	 When you release the mouse button the Make Widget dialogue box is displayed.
4.	 Select Actions.

5.	 Select Set.
6.	 Click OK.
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13.7.1.8	 Add a Link to Another Page

1.	 Navigate to the PX Page that is to be linked to using the Nav tree.
2.	 Click and drag the PX Page to the layout grid and position as required.

Note: As you drag the item on the page two green lines indicate the top left corner where the item will be 
positioned.

3.	 When you release the mouse button the Make Widget dialogue box is displayed.
4.	 Select From Palette.

5.	 Open the KitPx palette - see “Palettes” on page 106.
6.	 Select HyperlinkButton.
7.	 Select the Hyperlink check box.
8.	 Enter the required text in the text box.
9.	 Click OK.
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13.7.1.9	 Add a Graph

1.	 Navigate to the required history using the Nav tree.
2.	 Click and drag the history to the layout grid and position as required.

Note: As you drag the item on the page two green lines indicate the top left corner where the item will be 
positioned.

3.	 When you release the mouse button the Make Widget dialogue box is displayed.
4.	 Select From Palette.

5.	 Open the webChart palette - see “Palettes” on page 106.
6.	 Select Chart.
7.	 Click OK.
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13.8	 Reuse PX Pages

PX Pages can be reused, saving significant engineering time.

Normally PX Pages are created by using a new view attached to a folder in a centralised structure. However, as each 
PX Page is created in the file system in the ‘px’ folder, it is possible  for a page to be reused by copying the file in the 
px folder and attaching it to the required folder.

1.	 Create a PX Page as required - see “Create a PX Page” on page 71.
2.	 In the Nav tree open My Host > Station(IQVISION) > Files > px.
3.	 Right click the PX Page that is to be reused and select Copy.
4.	 Right click px and select Paste. The Name dialogue box is displayed.

5.	 Enter a name for the PX Page.
6.	 Click OK. The PX Page will be added.
7.	 In the Nav tree open My Host > Station(IQVISION) > Config and navigate to where the PX Page is to be 

located.
8.	 Right click the folder and select New> Folder. The Name dialogue box is displayed.

9.	 Specify the page’s name e.g. ‘Floor 4’.
10.	 Click OK a folder is created.
11.	 Right click the folder you have just created and select Views > New View. The New Px View dialogue box is 

displayed.

12.	 Enter the name of the page created above in the View Name box.
13.	 Click OK. The File already exists dialogue box is displayed.

14.	 Click Reuse.
15.	 Edit the page as required - see “Edit a PX Page” on page 71.
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13.8.1	 Reuse a Generic PX Page

Terminal controllers often have the same strategy and the associated PX Pages are identical, but reference data from 
different controllers.

To reduce engineering time a PX Page with generic references to data in the controller can be used for multiple 
controllers by attaching it to the required controllers in the Nav tree. In order for this to work any reference to the 
controller must be made generic, and the PX Page must be associated with the controller not a folder.

Create a generic PX Page:
1.	 Create a PX Page as required - see “Create a PX Page” on page 71.
2.	 Open the Bound Ords pane.
3.	 Double click on the first ord that references a value in the controller. The Edit ord dialogue box is displayed.

4.	 Edit the ord to make it generic by removing references to the site, LAN, and controller. E.g.

station:|slot:/Drivers/Trend$20Control$20Systems/Tech$20Pubs$20Rig/L024/O064/points/S/S0003

which is referencing sensor module 3 in controller 64 on LAN 24 of the Tech Pubs site would become:

slot:points/S/S0003

5.	 Click OK.
6.	 Press CTRL+S to save the page.

Associate a PX Page with a controller:
1.	 Right click the PX Page that is to be reused and select Copy.
2.	 Right click the px folder in the Nav tree and select Paste. The Name dialogue box is displayed.

3.	 Enter a name for the PX Page (e.g. Generic).
4.	 Click OK.
5.	 In the Nav tree navigate to the controller that the page is to be associated.
6.	 Right click the controller and select Views > New View. The New Px View dialogue box is displayed.

7.	 Enter the name of the page created above in the View Name box.
8.	 Click OK. The File already exists dialogue box is displayed.

9.	 Click Reuse.
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13.9	 Dashboards

A Dashboard is an element on a PX Page which each user can customise to their requirements.

To use dashboards the Dashboard palette needs to be opened, see “Palettes” on page 106, and the Dashboard 
Service needs to be added to the Services section of IQVISION.

Dashboard panes are added to the PX view like any other Graphic, but require some extra configuration.

13.9.1	 Add the Dashboard Service

1.	 In the Nav tree open My Host > Station(IQVISION) > Config > Services.
2.	 Open the Dashboard palette, see “Palettes” on page 106 and drag DashboardService onto Services. The 

Name dialogue box is displayed.

3.	 Click OK.

13.9.2	 Add a Dashboard to a PX Page

1.	 Create the PX Page as required.
2.	 Open the Dashboard palette, see “Palettes” on page 106, and drag DashboardPane onto the page.
3.	 Open the webchart palette - see “Palettes” on page 106.
4.	 Drag either Chart or Circular Gauge onto the content of the Dashboard pane in the widget tree.
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14	 SET UP IQVISION USERS

IQVISION’s security is controlled by users. The access rights of each user determines what information the user can 
access and what things they are able to change/configure.

To achieve this the security within IQVISION is managed using three services:

Categories
Roles
Users

Categories
Categories define what areas of the system a user can access.

Roles
Roles are used to group the categories together that are required for a particular job and to define the level of access 
to those categories.

E.g. a boiler engineer would only need access to the boilers but would require a high level of access. Therefore a role 
would be required for the engineers that gave high level access to the category that gave access to the boilers.

An energy manager would need information from all the plant but with a lower level of access. Therefore a role would 
be required for the energy manager that gave low level access to a number of categories covering all the plant.

Categories are assigned to roles using the Category Browser which is just another way of looking at the Nav tree.

Users
Users define which roles the user has, their password, expiry, web access view.

The ‘admin’ user is a superuser level access which has access to the whole system. Because of this details of the 
admin user’s password should carefully controlled.

To configure users the required steps should be followed:

Configure Categories
Configure Roles
Configure Users

14.1	 Configure Categories

Before creating the necessary categories it is necessary to plan what is required, you should consider the users and the 
distinct areas, then work out ‘Where’ needs to be granted access and create a category for each of these.

To configure categories the required steps should be followed:

Add a Category
Set up the Categories

14.1.1	 Add a Category

User and Admin categories are created by default and additional categories are added using the Category Manager.

Note: The Admin category does not relate to the Admin user used to engineer IQVISION.

1.	 In the Nav tree open My Host > Station(IQVISION) > Config > Services.
2.	 Double click CategoryService. The CategoryBrowser is displayed in the view pane.
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3.	 Click the view changer box and select Category Manager. The Category Manager is displayed in the view 
pane.

4.	 Click New. The New dialogue box is displayed.

5.	 Click OK. The dialogue box changes.

6.	 Enter the name of the category in the Name box.
7.	 Click OK.
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14.1.2	 Set up the Categories

1.	 In the Nav tree open My Host > Station(IQVISION) > Config > Services.
2.	 Double click CategoryService. The CategoryBrowser is displayed in the view pane.

3.	 Grant each category access to the required areas of the system by clicking the required rows in the column 
for each category. To grant access to elements lower in the hierarchy expand the appropriate row and click.

Note: Categories are a parent child system so selecting the top level will grant access to every child element 
under that level.

The inherit feature enables the access of the User category to be copied to another category. If there is a tick on 
the Inherit column for a row when that row is selected for another category the access from the User category 
is copied to the other category and removed from the User category. To reinstate access to the User category 
click the row in the User column.

Caution: Due to this it is potentially easy to accidentally remove rights.

A dot in a cell indicates access to that specific area. If the dot is black the access will not be affected by the 
Inherit tick, if it is grey it will be affected.

It is recommended that the Admin category is given the same access in the Config row as the User category 
i.e. leave the Inherit rows in the Config row are they are. For the other rows (Alarm, Files, and History) the 
Inherit rows can be unticked to enable you to specify the access more easily.

Note: By default the ‘Admin’ and ‘New’ categories will have no access.

Note: It is recommended that the ‘Admin’ category has access to some of the more complex areas of IQVISION 
but not the whole of IQVISION.

4.	 Click .
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14.2	 Configure Roles

Roles use the categories to define what areas of the system can be accessed. They can have multiple categories 
assigned. It is best to configure Roles with job roles in mind rather than specific areas like categories.

1.	 In the Nav tree open My Host > Station(IQVISION) > Config > Services.
2.	 Double click RoleService. The Role Manager is displayed in the view pane.

3.	 Click New. The New dialogue box is displayed.

4.	 Click OK. The dialogue box changes.

Note: It is recommended that the SuperUser (access entire station, file system) check box is NOT selected.

5.	 Click >> next to Permissions. The Permissions dialogue box is displayed.
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6.	 Specify the permissions for each category by clicking the appropriate column for each category. 

When you assign permissions, higher-level permissions (green check marks) automatically include the lower 
level ones (grey check marks). For example, if you enable admin level write (W), the system automatically 
enables admin level read (R), as well as operator level read and write (RW).

The first column, Category, lists the groups to which you may grant permission. The Operator and Admin 
columns relate to the permissions level configured on each component. Below these headings are the cells to 
use for assigning one of three permissions to each category:

R Read allows the user to view the object.
W Write allows the user to change the object.
I Invoke allows the user to initiate an action related to the object.

Depending on how the permission level is set on the role, six permissions are derived:

Permission Description
To allow a user to view operator level 
information

Check the Operator config flag on the slot and select the Operator 
R column on the permission map.

To allow a user to modify operator level 
information (if it is not read only)

Check the Operator config flag on the slot and select the Operator 
W column on the permission map.

To allow the user to view and invoke 
operator-level operations (actions)

Check the Operator config flag on the slot and select the Operator 
I column on the permission map

To allow the user to view admin level 
information

Leave the Operator config flag unchecked on the slot and select 
the Admin R column on the permission map.

To allow the user to modify admin level 
information (if it is not read only)

Leave the Operator config flag unchecked on the slot and select 
the Admin W column on the permission map.

To allow the user to view and invoke 
admin-level operations (actions)

Leave the Operator config flag unchecked on the slot and select 
the Admin I column on the permission map.

7.	 Click OK.
8.	 Click OK. A confirmation dialogue box is displayed.
9.	 Click Yes.
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14.3	 Configure Users

To configure users the required steps should be followed:

Configure NAV Files
Add Users

14.3.1	 Configure NAV Files

NAV files are used to define the PX Page that is displayed when a user logs in. Each user must have a NAV file 
assigned. It is recommend that a folder is created to store all the NAV files.

14.3.1.1	 Create a Folder for the NAV Files

1.	 Right click Files and select New> Folder. The Name dialogue box is displayed.

2.	 Specify the folders’s name e.g. ‘NAV’.
3.	 Click OK.

14.3.2	 Create NAV Files

1.	 In the Nav tree open My Host > Station(IQVISION) > Config and navigate to where the NAV file is to be 
located e.g. the folder created in Create a Folder for the NAV Files.

2.	 Right click the folder and select New> NavFile.nav. The Name dialogue box is displayed.

3.	 Specify the file’s name e.g. ‘Home’.
4.	 Click OK. The file is created.
5.	 Open the folder containing the NAV file.
6.	 Double click the NAV file. The Nav File Editor is displayed in the view pane.

7.	 Click Show Components.
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8.	 In the Result Tree double click the NAV file. The Edit dialogue box is displayed.

9.	 Click  next to DefaultView. The Select Ord dialogue box is displayed.

10.	 Navigate to the PX Page that is to be referenced by the NAV page and select it.
11.	 Click OK.
12.	 Click OK.

14.3.3	 Add Users

1.	 In the Nav tree open My Host > Station(IQVISION) > Config > Services.
2.	 Right click UserService and select Views > AX User Manager. The Ax User Manager is displayed in the 

view pane.

3.	 Click New. The New dialogue box is displayed.

Note: Several users can be added at the same time. However, it is recommended to add users individually to 
prevent confusion when specifying passwords.
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4.	 Click OK. The dialogue box changes.

5.	 Enter the user’s username in the Name box.
6.	 Enter the users full name in the Full Name box.
7.	 If the user is to expire on a specific date select the Expires On option and specify the required date.
8.	 Select the roles for the user in the Roles box.
9.	 Enter the user’s password in the Password box.

Note: Passwords must be 10 digits alpha numeric.

10.	 Re-enter the user’s password in the Confirm box.
11.	 To force the user to change the password when they next login set Force Reset At Next Login to true.
12.	 To force the user to change the password on a specific date, select the Expires On option and specify the 

required date.
13.	 If the password is to expire on a specific date select the Expires On option and specify the required date.
14.	 Specify the NAV file that is linked to the PX Page that is to be displayed when the user logs in in the Nav file 

box.
15.	 Specify what happens when a user logs in from a web browser in the Default Web Profile box.

▪▪ In the Type box select the required option.

It is recommend that you select HTML5 Hx Profile as it will render the graphics in a HTML5 format 
avoiding Java issues.

▪▪ In the Hx Theme box select IQVision.
▪▪ Select Yes or No to specify whether the user has access to the following features:

▪▪ Hx workbench views
▪▪ Nav tree side bar
▪▪ search side bar
▪▪ palette side bar
▪▪ Nav file tree
▪▪ Config tree
▪▪ Files tree
▪▪ Histories tree
▪▪ Hierarchies tree

16.	 In the User Pin Level box specify the PIN level of the user that is used to determine access to items on PX 
pages that have been imported from 963 using the Migration Tool.

17.	 Click OK.
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15	 BACKUP & RESTORE

To ensure that the IQVISION configuration can be restored in the event of hardware or software failure it is 
recommended that the IQVISION station is backed up. To reduce the risk it is recommended that the backup is 
performed in two ways:

Using the Station Copier
Using the Backup Service

It is also important to ensure that the passphrase entered during the IQVISION installation, platform password 
(normally PC login credentials) and the password for the ‘admin’ user (specified when creating the IQVISION 
station) are available for use during any restore procedure.

15.1	 Backup the Configuration

15.1.1	 Using the Station Copier

The IQVISION configuration can be copied from the localhost back to the local computer. This is not a true back 
up but it is useful as it makes the configuration available offline and thus reusable in future IQVISION installations.

1.	 In the Nav tree right-click on Platform and select Views > Station Copier. The Station Copier is displayed 
in the view pane.

2.	 In the right-hand column (Stations on “localhost”) click the station to be copied (e.g. IQVISION). 

The Localhost is the live version of IQVISION. Copying from left to right will overwrite the live version with 
an older PC version. To copy the live version to the PC it is RIGHT to LEFT

3.	 Click < Copy. The Station Transfer Wizard is displayed.
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4.	 Enter the name of the backup copy (e.g. IQVISION Backup).
5.	 Click Next. 

6.	 Select Copy every file in the station directory and its subdirectories.
7.	 Click Next.
8.	 If the station already exists in the destination you will be prompted to delete the entire station, or just overwrite 

duplicate files. Select the required option and click Next.

9.	 Click Finish to start copying the files. Once the copy is complete the following dialogue box is displayed.

10.	 Click Close.
11.	 In the Nav tree open My File System and navigate to C:/Users/xxxxxx/Niagara4.2/Trend/stations where 

xxxxxx is your user name.
12.	 Right-click the required station folder and select Copy.
13.	 Navigate to the required storage location (e.g. a plug-in memory device).
14.	 Right-click and select Paste.
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15.1.2	 Using the Backup Service

Station backups are stored as ‘.dist’ files in C:/Users/xxxxxx/Niagara4.2/Trend/backups where xxxxxx is your user 
name.

1.	 In the Nav tree open Station > Config > Services.
2.	 Right click Schedules and choose Views > Ax Property Sheet.

3.	 In the Exclude Directories box click file:^^history and click .
4.	 In the Exclude Directories box click file:^^alarm and click .
5.	 Click Save.
6.	 In the Nav tree double click BackupService. The Backup Manager is displayed in the view pane.
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7.	 Click Backup. The File Chooser dialogue is displayed.

8.	 If required rename the backup in the File name box.
9.	 Click Save.
10.	 Ensure the backup file is stored securely.

15.2	 Restore the Configuration

15.2.1	 Restore Using the Station Copier

To restore a station copy follow the procedure described in “Using the Station Copier” on page 91 but copy the 
station from left to right.

15.2.2	 Restore the Station Using the dist file

1.	 Rename the backup.dist file to a zip by renaming the extension. 
2.	 Navigate to the station folder and copy it into the wb user home. 
3.	 Use the station copier to copy it to the daemon home and start.
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16	 MIGRATION TOOL

IQVISION includes a Migration Tool that can be used to import system data from other Trend tools. The tool is 
compatible with data exported from:

▪▪ 963 supervisor, 
▪▪ IQSET engineering tool.

Imported data can include device configurations and/or schematics.

HINT: Although you can migrate devices and schematics in a single pass, you may find it helpful to migrate devices 
and schematics separately.

16.1	 Exporting Data from Other Tools

Before using the migration tool it is necessary to export the required data from which ever tool(s) you have.

Device data is contained in a ‘.dxml’ file, and schematic data is contained in a ‘.sxml’ file

16.1.1	 963

You will need to download the latest version (v2.00 or above) of the 96x Schematic Export Tool from PNet. Run the 
tool and export the required schematic files.

Note: The Migration Tool does not migrate all 963 schematic items. It is recommend that the option to remove 
unsupported items from the export is selected when exporting the required schematic files.

Refer to the 96x Schematic Export Tool Manual (TE201242) for further details.

16.1.2	 IQSET

Load the required project into IQSET (v7.05 onwards), select the devices required and choose Export > IQVISION. 

Refer to IQSET Manual (TE200147) for further details.

16.2	 Copying Exported Files into IQVISION

1.	 In the Nav tree open My File System and navigate to the location of your exported file(s).
2.	 Right-click the file(s) or folder(s) required and select Copy.
3.	 In the Nav tree open the Station folder.
4.	 Right-click on Files and select Paste.
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16.3	 Using the Migration Tool

The Migration Tool will guide you through the process of migrating data from a 963 or IQSET project into IQVISION. 
You must first have exported files from 963 or IQSET and copied them into the Station > Files location on the 
IQVISION computer.

The tool guides you through a number of steps and will not allow you to proceed to the next step until you have 
completed any necessary tasks. In most cases you can go back to the previous step if you encounter any problems or 
want to change something.

To Migrate 963 and IQSET Data into IQVISION:
1.	 Click the  icon on the toolbar. The welcome page of the Migration Tool is displayed.

2.	 Click START. The Select page is displayed.
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3.	 Click the  icon and choose the location of the 963 or IQSET source file(s).

4.	 Click OK.
5.	 Deselect any unwanted data types (e.g. Devices or Schematics). All are selected by default and at least one 

must be selected.
6.	 Click NEXT. The Scan page is displayed and the tool will automatically scan the specified folder (or file) for 

the selected data. Progress is indicated by the spinning green circles.

When scanning is complete the number of devices and schematics found is displayed. 
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7.	 Click NEXT. The Configure page is displayed, showing a list of all of the devices and schematics that have 
been found.

8.	 Click the Devices tab and deselect any devices that you do not wish to migrate.
9.	 Click the Schematics tab and deselect any schematics that you do not wish to migrate.
10.	 If required, enter the Ip Address and VCNC Port number of the vCNC to be used to make a connection to the 

site. By default the address is set to l27.0.0.1 (i.e. the local host) and vCNC port is set to 10000. Alternatively, 
you can set this up later by configuring the Trend IP Driver for the site (see page 33).

11.	 Click NEXT. The following confirmation dialogue box is displayed.

12.	 Click YES to migrate all files. If the new data conflicts with any existing site, LAN, device or point details, 
the existing details is overwritten. Click NO to migrate only the details where there are no conflicts.
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The Migrate page is displayed and the tool will commence migration of the selected items. Progress is 
indicated by the spinning green circles.

When migration is complete the number of devices and schematics migrated is displayed.

13.	 Click NEXT. The Report page will appear allowing you to review which devices and schematics have been 
migrated and whether the migration was successful as indicated by the icons.

Icon Status
Fully migrated. No problems reported.
Partially migrated. 
Failed. Not migrated. 
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16.3.1	 Migrated Devices - Next Step

The Migration Tool creates and outputs device data to a folder called ‘Trend N4’ within the Station > Drivers 
section. Under this each set of devices is split into the relevant Trend LAN. For each device all points are split into 
sub folders. 

Histories (Plots) are automatically learnt and, by default, data is set to be collected from a plot module once daily at 
02:00:00 AM GMT. This can be altered as required for each history, and must be altered for plots with intervals of 1 
second or 1 minute to prevent data being lost. For example, assuming a plot module maintains a maximum of 1000 
plot records, 1 second plots must be collected at least once every 16 minutes, and 1 minute plots must be collected at 
least once every 16 hours.

16.3.2	 Migrated Schematics - Next Steps

The Migration Tool places all the recreated schematics files in a folder called ‘PX’ within the Station > Files section. 
The files are named according to their original name.

Review the schematic/PX Pages to check that they are as expected. Some minor editing of the font, size, colour and 
positioning of text may be required.



IQVISION Configuration Manual TE201382 Issue 4, 13-Feb-2017� 101

Using IQVISION

IQVISION Configuration Manual TE201382 Issue 4, 13-Feb-2017� 101

17	 USING IQVISION

This section covers the general procedures for day-to-day use of IQVISION. 

Once configured IQVISION needs to be running all the time to enable it to collect logged data, control occupation 
times, process alarms and allow users to access information.

If AUTO-START was selected when the IQVISION station was created, see “Create a New Station” on page 27, 
IQVISION will be running whenever the PC is started and running. If this is not the case the IQVISION station must 
be started manually - see “Start the IQVISION Station” on page 119.

17.1	 Access IQVISION

IQVISION can be accessed from a PC using the IQVISION application or from a web browser.

Note: When accessing IQVISION from a web browser not all features are available.

17.1.1	 Access IQVISION from the IQVISION Application

Launch the IQVISION Application
Log on

17.1.1.1	 Launch the IQVISION Application

1.	 Click Start and choose All Programs.
2.	 Navigate to the Trend Control Systems > IQVISION folder.
3.	 Click IQVISION.

The IQVISION application window will open:

Note: For an overview of the IQVISION user interface see page 106.
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17.1.1.2	 Log on

1.	 In the Nav tree double click on Station. The Authentication dialogue box is displayed with a default user 
selected:

2.	 To select a different user click Change User, otherwise go to step 5.

Hint: Select the Remember this user tickbox to make this the default username.

3.	 Enter a new Username.
4.	 Click OK.
5.	 Type the appropriate password in the Password box.
6.	 Click OK.

17.1.1.3	 Log off

When you have finished using IQVISION it is important to log off from IQVISION to ensure that the system cannot 
be accessed by unauthorised users. Logging off requires you to disconnect from both the Platform and Station.

1.	 In the Nav tree right-click on My Host and select Disconnect. The Disconnect dialogue box is displayed.

2.	 Click Yes to disconnect.
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17.1.2	 Access IQVISION from a Web Browser

1.	 Go to the IP address of the PC running IQVISION. The IQVISION log on page is displayed.

2.	 Enter your user name.
3.	 Click Login.
4.	 Enter your password.
5.	 Click Login.

17.1.2.1	 Log off

1.	 Click .
2.	 Click Yes.
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17.2	 Use IQVISION

Once you have accessed IQVISION it can be used in two different ways:

Using IQVISION via PX Pages
Using IQVISION via the Nav Tree

The method you use will depend on how IQVISION has been configured, your level of access and the tasks you want 
to do.

17.2.1	 Using IQVISION via PX Pages

Use of IQVISION via PX Pages requires more initial configuration, but enables users to access the system using 
graphical pages tailored to their requirements in a controlled way.

The PX Pages will have been designed to provide clickable links to either move between pages or select particular 
controls (e.g. to change a set point, change occupancy times, etc). When you log in you will be taken to a landing page 
from which you can navigate to the required information and, if allowed, make adjustments. Simply click on the links 
provided; the user interface should make it obvious what the link does.

Access the PX Pages
Use the PX Page
Use Dashboards

17.2.1.1	 Access the PX Pages

When you log on a PX Page will normally be displayed allowing you to navigate to parts of the system that you have 
access to. 

If a PX Page is not displayed and you want to navigate the system using PX Pages you will need to display the 
required page from the Nav tree.

1.	 In the Nav tree open My Host > Station(IQVISION) > Config and navigate to the required PX Page.
2.	 Double click the page. 

17.2.1.2	 Use the PX Page

Navigation
Once a PX Page is displayed you will be able to navigate to other parts of the system by clicking on the links 
provided. These links may be in the form of text hyperlinks buttons, or graphics with hyperlinks depending on how 
the page has been configured. The display should make it clear the function of each item on the page.

The next and previous buttons ( ) can be used to move between the pages you have already viewed.

Adjustments
If you have the authority and the page has been configured appropriately you may be able to make adjustments by 
clicking on various graphical elements, e.g. sliders and buttons.

     
The meaning and use of such items should be intuitive.



IQVISION Configuration Manual TE201382 Issue 4, 13-Feb-2017� 105

Using IQVISION

IQVISION Configuration Manual TE201382 Issue 4, 13-Feb-2017� 105

17.2.1.3	 Use Dashboards

A Dashboard is an item on a PX Page that enables you to choose the information that is displayed. Once you have set 
up the item it can be saved so that next time you visit the page your selections are visible. Selections made by other 
users do not affect yours. A PX Page may contain one or more dashboard items.

There are two types of dashboard item; Gauges and Charts.

Gauge
A gauge type dashboard appears as shown below and enables an analogue value to be represented in a graphical way.

Un configured         Configured

Chart
A chart type dashboard appears as shown below and enables values to be represented as a graph, e.g. histories. Time 
schedules can also be added enabling you to view the occupancy state and when a parameter is at a certain value.

Un configured         Configured

17.2.1.3.1	 Configuring a Dashboard

Note: Configuring a dashboard requires access to the Nav tree.

Adding an item to a Dashboard
1.	 Use the Nav tree to locate the point required.
2.	 Drag the point onto the dashboard. For charts you can add more than one value.

Save a Dashboard
1.	 Click  on the dashboard.
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17.2.2	 Using IQVISION via the Nav Tree

17.2.2.1	 Basic Controls and Navigation

To see the location of the following IQVISION controls and features, refer to the diagram on page 11.

17.2.2.1.1	 Nav Tree

To show the side bar:
1.	 On the menu bar select Window > Side Bars and ensure Show Side Bars is checked.

To add a Nav tree to the side bar:
1.	 On the menu bar select Window > Side Bars > Nav.

To remove a Nav tree from the side bar:
1.	 Click the arrow to the left of the Nav tree title and select Close.

17.2.2.1.2	 Palettes

To show the side bar:
1.	 On the menu bar select Window > Side Bars and ensure Show Side Bars is checked.

To add a Palette to the side bar:
1.	 On the menu bar select Window > Side Bars > Palette.
2.	 Click the file icon and select the Palette type from the displayed options.

To remove a Palette from the side bar:
1.	 Click the arrow to the left of the Palette title and select Close.

17.2.2.1.3	 Locator Bar

To navigate down the hierarchy:
1.	 Holding the mouse over an item: a small arrow will appear. 
2.	 Click the arrow to reveal a drop down box and select the required option.

To navigate up the hierarchy:
1.	 Click on an item in the bar to navigate back to that level. 

To navigate to specific location:
1.	 Click in a blank area of the locator bar and type the path directly into the box.

17.2.2.1.4	 View Pane & View Changer

To change the view of a selected item:
1.	 Click the view changer box and choose the required view.

Or

Right-click the item (e.g. in the Nav tree), then select Views > and the required view.
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17.2.2.2	 Viewing and Changing Point Values

To view a point value:
1.	 Use the Nav tree to locate the point required.
2.	 Double click the point (or right-click and select Views > AX Property Sheet) to view its Property Sheet. The 

Out item will indicate the current point value.

To change a point value (writable points only):
1.	 Use the Nav tree to locate the point required, right-click the point and select Actions > Set Value.

Or 

Click the button that allows the value to be adjusted.

The Set dialogue box is displayed.

2.	 Type the required value.

Note: IQVISION does not check that the value entered is valid.

3.	 Click OK.

17.2.2.3	 Viewing Alarms

17.2.2.3.1	 Viewing Alarms Using the Alarm History

1.	 In the Nav tree open the Services folder (under Station > Config).
2.	 Right-click AlarmService and select Views > Alarm Db View. The Alarm History is displayed in the view 

pane.

3.	 Use the selector box (top left) to choose the required period.
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17.2.2.3.2	 Using the Alarm Console

The Alarm Console allows you to view details of each alarm, acknowledge an alarm or add notes to alarms. Notes are 
useful to record actions (particularly for critical alarms) such as who has been notified, contact numbers and agreed 
timescales for fixing the problem.

To view specific alarm details:
1.	 In the Nav tree open the Station > Config > Services folder.
2.	 Double click AlarmService. The view pane will display the Alarm Service wire sheet.
3.	 Double click on the required ConsoleRecipient to open the Alarm Console:

Note: Current alarms are indicated by a red icon, cleared alarms are indicated by a green icon.

4.	 Double click an alarm line to open the Alarm Viewer. This will list all current and cleared alarms related to 
the same alarm condition:

5.	 Double click an alarm to open the Alarm Record, giving full details of the alarm.

To acknowledge an alarm:
1.	 Click the alarm in the Alarm Console or Alarm Viewer or open the Alarm Record for a specific alarm.
2.	 Click the Acknowledge button.

Note: Multiple alarms can be selected and acknowledged at the same time in the Alarm Console or Alarm 
Viewer by clicking in conjunction with CTRL and/or Shift keys.

To view or add notes for an alarm:
1.	 Click the alarm in the Alarm Console or Alarm Viewer or open the Alarm Record for a specific alarm.
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2.	 Click the Notes button. The Notes window is displayed and any previously added notes will be shown with a 
timestamp in the top section:

3.	 Type any new details in the lower section and click the Add Note button to save, or click Close to close the 
window without adding a new note.

Note: You cannot add notes to multiple alarms.
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17.2.2.4	 Viewing and Changing Occupation Times (Time Schedules)

To view occupation times:
1.	 In the Nav tree open the Schedules folder for the required controller.
2.	 Double click the required the read-only ‘Import’ schedule. The Scheduler is displayed.

To change occupation times:
1.	 In the Nav tree, expand the read-only ‘Import’ schedule that you want to change.
2.	 Double click the ext (extension). The Schedule Home is displayed.

3.	 Click the Read Schedule from IQ controller button to get the latest data from the controller. Progress/status 
messages are displayed at the bottom of the screen.

Note: The data is automatically refreshed once a day.

4.	 Click the Refresh button to update the display.
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5.	 Specify the required occupation times:

▪▪ To add a new time period: Drag the mouse in the required white area of the grid.
▪▪ To make adjustments to existing time periods: Drag the top or bottom edge of the green rectangles 

to the required time. 
▪▪ To set all day occupation: Right click the day and select All Day Event.
▪▪ To a apply a period a day’s times Monday to Friday: Right click the day and select Apply M-F.
▪▪ To remove a time period: Right-click the rectangle and select Delete Event.
▪▪ To remove all time periods for a day: Right click the day and select Clear Day.
▪▪ To copy a day: Right click the day and select Copy Day then right click the day the times are to be 

copied to and select Paste Day.

6.	 Click Save.
7.	 Click Write Schedule to IQ controller to trigger an immediate download to the controller. Progress/status 

messages are displayed at the bottom of the screen.

Note: The data is automatically refreshed once a day.

To add Special Events (exceptions):
1.	 In the Nav tree, expand the read-only ‘Import’ schedule that you want to add an event to.
2.	 Double click on the auto-generated ext (extension). The Schedule Home is displayed.
3.	 Click the Special Events tab:

4.	 Click Add. The Add dialogue box is displayed.

5.	 Give the event a suitable Name (e.g. Bank Holiday) and enter the required date information.
6.	 Click OK.
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7.	 Drag the mouse in the time table to set the required ‘on/true’ time(s).

▪▪ To add a new time period: Drag the mouse in the required white area of the grid.
▪▪ To make adjustments to existing time periods: Drag the top or bottom edge of the green rectangles 

to the required time. 
▪▪ To set all day occupation: Right click the day and select All Day Event.
▪▪ To remove a time period: Right click the rectangle and select Delete Event.
▪▪ To remove all time periods: Right click the day and select Clear Day.

8.	 Right click in the white ‘Unscheduled’ area of the time table and select Schedule Defaults. This will set the 
appropriate ‘off/false’ time periods.

9.	 Click Save.
10.	 Click the Write Schedules from IQ controller button to trigger an immediate download to the controller. 

Progress/status messages are displayed at the bottom of the screen.

Note: The data is automatically refreshed once a day.
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17.2.2.5	 Controlling Occupation Times Centrally

If IQVISION has been configured to control occupation times centrally, see “Controlling Complex Occupation 
Times” on page 53, the times can be changed in several ways depending on the configuration.

Changing the Weekly Schedule
Editing Special Events
Editing the CalendarSchedule

17.2.2.5.1	 Changing the Weekly Schedule

The weekly schedule determines the occupation times for a normal week, i.e. no Special Events apply.

1.	 In the Nav tree open My Host > Station(IQVISION), navigate to the required BooleanSchedule.
2.	 Double click the BooleanSchedule. The Scheduler is displayed in the view pane.

3.	 Select the Weekly Schedule tab.
4.	 Specify the required occupation times:

▪▪ To add a new time period: Drag the mouse in the required white area of the grid.
▪▪ To make adjustments to existing time periods: Drag the top or bottom edge of the green rectangles 

to the required time. 
▪▪ To set all day occupation: Right click the day and select All Day Event.
▪▪ To a apply a period a day’s times Monday to Friday: Right click the day and select Apply M-F.
▪▪ To remove a time period: Right-click the rectangle and select Delete Event.
▪▪ To remove all time periods for a day: Right click the day and select Clear Day.
▪▪ To copy a day: Right click the day and select Copy Day then right click the day the times are to be 

copied to and select Paste Day.

5.	 Click Save.
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17.2.2.5.2	 Editing Special Events

Special events enable different occupation times to be used on specific days.

1.	 In the Nav tree open My Host > Station(IQVISION), navigate to the required BooleanSchedule.
2.	 Double click the BooleanSchedule. The Scheduler is displayed in the view pane.
3.	 Select the Special Events tab.

4.	 Specify the required Special Events:

Add a special event
▪▪ Click Add. The Add dialogue box is displayed.

▪▪ Specify a name for the special event in the Name box.
▪▪ Select Date or Date Range in the Type box.

Do NOT select any of the other options in the Type box as they are not supported by the controller 
and will cause problems.

▪▪ Specify the date(s) the special event applies to:

Date: Specify the day month and year in the appropriate box.
Date Range: Specify the day month and year for the beginning of the range in the appropriate box in 
the top row and specify the day month and year for the end of the range in the appropriate box in the 
bottom row

▪▪ Click OK.
▪▪ Edit the times - see “Edit the times” on page 115.
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Edit the times
▪▪ Click the special event for which the times are to be edited.

▪▪ To add a new time period: Drag the mouse in the required white area of the grid.
▪▪ To make adjustments to existing time periods: Drag the top or bottom edge of the green rectangles 

to the required time. 
▪▪ To set all day occupation: Right click the day and select All Day Event.
▪▪ To remove a time period: Right click the rectangle and select Delete Event.
▪▪ To remove all time periods: Right click the day and select Clear Day.

▪▪ To ensure non-occupancy outside the specified periods right click the day and select Schedule Defaults.

Rename a special event
▪▪ Right click the special event that is to be renamed.
▪▪ Click Rename. The Rename dialogue box is displayed.

▪▪ Enter the new name.
▪▪ Click OK.

Delete a special event
▪▪ Right click the special event that is to be deleted.
▪▪ Click Delete. The Confirm dialogue box is displayed.

▪▪ Click Yes.

5.	 Click Save.
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17.2.2.5.3	 Editing the CalendarSchedule

If a CalendarSchedule has been added to specify days different occupation times are used, these days can be edited 
by add or removing events from the CalendarSchedule.

1.	 In the Nav tree open My Host > Station(IQVISION), navigate to the required BooleanSchedule.
2.	 Double click the CalendarSchedule. The Scheduler is displayed in the view pane.
3.	 Select the Special Events tab.

4.	 Specify the required date:

Add a date
▪▪ Click Add. The Add dialogue box is displayed.

▪▪ Specify a name for the special event in the Name box.
▪▪ Select Date or Date Range in the Type box.

Do NOT select any of the other options in the Type box as they are not supported by the controller 
and will cause problems.

▪▪ Specify the date(s) the special event applies to:

Date: Specify the day month and year in the appropriate box.
Date Range: Specify the day month and year for the beginning of the range in the appropriate box in 
the top row and specify the day month and year for the end of the range in the appropriate box in the 
bottom row.

▪▪ Click OK.
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Edit a date
▪▪ Double click the date that is to be edited. 
▪▪ Edit the date as required.

Rename a date
▪▪ Right click the date that is to be renamed.
▪▪ Click Rename. The Rename dialogue box is displayed.

▪▪ Enter the new name.
▪▪ Click OK.

Delete a date
▪▪ Right click the date that is to be deleted.
▪▪ Click Delete. The Confirm dialogue box is displayed.

▪▪ Click Yes.

5.	 Click Save.
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17.2.2.6	 Viewing a History (Graph)

1.	 In the Nav tree open the History folder (Station > History).
2.	 Open the folder for the required controller.
3.	 Double click on the history that you wish to view. The Chart view is displayed.

17.2.2.6.1	 Viewing Multiple Plot Graphs

To add another plot to the same chart:
1.	 Drag the required history from the Nav tree onto the Chart view.

17.2.2.6.2	 Adjusting the Displayed Information

To change the displayed time period:
1.	 Use the selector (at the top left of the Chart view) to choose the required time period.

To change the horizontal scale:
1.	 Mouse over the appropriate scale until the cursor changes to a double arrow.
2.	 Drag the mouse left or right to change the scale.

To change the vertical scale:
1.	 Mouse over the appropriate scale until the cursor changes to a double arrow.
2.	 Drag the mouse up or down to change the scale.

17.2.2.6.3	 Viewing the Source Data

To view the source data in table form:
1.	 Click the View Changer and select History Table.

17.2.2.6.4	 Exporting a Graph or Data Table

1.	 In the Nav tree, right-click on the required history and select Export. The Export dialogue box is displayed.
2.	 In the Select Exporter box select the required export type and file format.
3.	 Choose the export method (e.g. Save to File).
4.	 Click OK.
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17.2.2.6.5	 Viewing Live Updates

1.	 View the desired plot (as described above) and change the view to History Chart.
2.	 Click the Play button  to start getting history updates. At the bottom right corner of the window the 

message ‘Waiting on first Live Update...’ will appear.
3.	 When the time period (setup in 8.2.7) has elapsed the message will change to show ‘Last Live Update’ with 

the date and time of the update.

Note: If you zoom in on the chart, live updates will not be visible anymore. If you need to see values that are 
not visible on the chart you need to switch to History Table view - see 17.2.2.6.4.

17.3	 Start the IQVISION Station

1.	 In the Nav tree open My Host > Station(IQVISION) > Platform > Services.
2.	 Double click Application Director. The Application Director is displayed in the view pane.

3.	 Click Start. The station will be started, check that a ‘Station Started’ message is shown.
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Using the Extended Support Options

APPENDICES

A1	 USING THE EXTENDED SUPPORT OPTIONS

IQVISION has the following extended support options that can be purchased:

IQV-OPC		  Extend the open protocol points with OPC client connectivity
IQV-DB-CSV 	 Extend the capability for the supervisor to interact with Microsoft Excel
IQV-DB-SQL 	 Extend the capability for the supervisor to communicate SQL

In order to use these options it is necessary to licence IQVISION with the appropriate licence - see “Licensing 
IQVISION” on page 23.

For details of configuring and using these option refer to the Tridium documentation.
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